Make index || portsdb -uU fails after cvsup

Kent Stewart kstewart at
Sat May 8 20:24:29 PDT 2004

On Saturday 08 May 2004 07:36 pm, Garance A Drosihn wrote:
> Hmm.  Well, I am baffled here.
> This week I tried to do a `make index' for the first time in
> awhile, and it failed for me on both a 4.x and 5.x system.  I
> do not understand why no one else seems to be seeing this.  The
> error I see is:
> (10) make index
> Generating INDEX - please wait..make: don't know how to make
> _accessibility.describe. Stop
> *** Error code 2
> make: don't know how to make _arabic.describe. Stop
> *** Error code 2
> 2 errors
> Now that I've made it to the weekend and no one else has reported
> this, I started to look into it.  From what I can see, it seems to
> me that update v1.53 should break `make index' for everyone, the
> same way it's broken for me.  And yet, that change was commited over
> a month ago.  I can not believe I'm the first person to do a make
> index in over a month!

Just as a test, I tried doing a "make describe" from /usr/ports/arabic 
and had no problem. I did a rm -rf * and cvsup'ed and had no problem 
doing the make describe.

So, the first questions that come to mind are did you cvsup ports-all 
and do you have any refuses.


> I'll also admit that I do not quite understand what that section
> of the makefile is doing, but I changed it to something which
> seemed more understandable to me, and `make index' now seems to
> be working for me.
> The quick change I made was:
> ---	Fri Apr  2 02:25:23 2004
> +++	Sat May  8 21:39:42 2004
> @@ -209,7 +209,9 @@
>   .for i in ${SUBDIR}
>   describe.$i:
> -	@${MAKE} -B ${i:S/^/_/:S/$/.describe/} >
> ${INDEX_TMPDIR}/${INDEXFILE}.desc.${i}
> +	@cd ${.CURDIR}/${i}; \
> +	echo "`date +%T` in `pwd`" ; \
> +	${MAKE} -B describe > ${INDEX_TMPDIR}/${INDEXFILE}.desc.${i}
>   .endfor
>   .else
>   describe: ${SUBDIR:S/^/_/:S/$/.describe/}
> (apologies if my email client mangles that...)
> Comparing the BUILDING_INDEX version of the "describe" target to
> the plain one, I could not see why one had to `cd' into each
> ports-subdirectory, and the other one didn't, so I added that.
> I also added the `echo' statement just for debugging purposes.
> So, which episode of Twilight Zone am I on that this only seem
> to be effecting me?

Kent Stewart
Richland, WA

More information about the freebsd-ports mailing list