autoconf/automake guru wanted [gnuplot-4.0 with patches]

Daniel Roethlisberger daniel at
Sat May 1 07:45:55 PDT 2004

Fernan Aguero <fernan at> [2004-04-28/12:01]:
> After applying the patches I ran autoconf259 (I also have autoconf213
> in my system), which gave no error or signs.  Next, I ran configure
> using the new options '--enable-datastrings and --enable-histograms'.
> Configure does not produce any errors, however upon calling 'make'
> there are some errors about missing 'aclocal', 'autoheader',
> 'autoconf' and then a re-check happens which re-runs configure and
> make. At this time there are errors about a missing 'automake-1.7'.

I am neither an autotools guru nor a ports guru, so take the following
with a grain of salt.

When working with autoconf et al on FreeBSD outside the ports
environment, I found that they need some $PATH tweaking in order to find
the correct version of their companion tools. When the tools call each
other, they sometimes just run plain `aclocal', `autoheader',
`autoconf', `automake' instead of the correctly versioned commands
`autoconf257' or `automake17'. This either causes the wrong version of
the tools to be called, if you have the `default' automake15/autoconf253
ports installed, or you see complaints about missing tools.

To fix this, I am currently using symlinks pointing to the correct
versions in ~/bin/ (which I include in front of the normal $PATH). This
works for me.

However, I think there might be a bug in the automake17 port which
causes calls to `automake-1.7' to appear in generated Makefiles. I have
not had time to investigate this any further, and I haven't written a PR
about this, so I might be all wrong. The autotools have changed to
install versioned command names upstream, but using a different naming
scheme than FreeBSD ports do (`automake17' vs. `automake-1.7'), and
maybe there was an occurence of `automake-1.7' that was overlooked when
the port was prepared.


Daniel Roethlisberger <daniel at>
GnuPG key ID 0x804A06B1 (DSA/ElGamal)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list