Probelms and Inconsistencies with Portupgrade

Aeefyu afu-subscribed-list at
Thu Mar 25 18:37:38 PST 2004

Lowell Gilbert wrote:
> Aeefyu <afu-subscribed-list at> writes:
>>Have been cvsup-ing for couple of days with the same
>>results. /usr/ports/INDEX is updated correctly, but will have errors
>>once I run portsdb -Uu. As of yesterday, I am skipping the "portsdb
>>-Uu" step after cvsup-ing ports-all. This is NOT a correct behaviour
>>for using portugrade, right? 

> When I'm having trouble building an INDEX, I run "make describe" and
> see where it fails; that usually gives me the information I need to
> fix it.
> Good luck.

"make describe" fails with the following:
What should these be telling me?


===> databases/mytop
mytop-1.4|/usr/ports/databases/mytop|/usr/local|A top clone for 
MySQL|/usr/ports/databases/mytop/pkg-descr|leeym at|databases||/usr/ports/databases/p5-DBD-mysql 
/usr/ports/devel/p5-Term-ANSIColor /usr/ports/devel/p5-Term-ReadKey 
===> databases/namazu2
*** Error code 1

Stop in /usr/ports/databases.
*** Error code 1

Stop in /usr/ports

"portinstall -RvF databases/namazu" gives me:

[1028][root at beta: ports]$ portinstall -RvF databases/namazu2
--->  Session started at: Fri, 26 Mar 2004 10:32:12 +0800
** No such installed package nor such port called 'databases/namazu2' is 
** No package has been fetched.
--->  Session ended at: Fri, 26 Mar 2004 10:32:12 +0800 (consumed 00:00:00)

mytop installs successfully - but running "mytop" fails witha 
segmentation fault.

The above has been done by building after re-building my ports tree from 

What manual steps or gotchas should i be aware of at this point?

Thanks again for your guys/gals time. Appreciated!

Webcraft Solutions -
Stop searching.  Happiness is right next to you.

More information about the freebsd-ports mailing list