[Mozilla Firefox report] Problem running firefox

Alexandre Ahmim-Richard passe at clope.net
Sun Mar 7 17:52:12 PST 2004


As said in the pkg-message :

- FreeBSD version : FreeBSD mulet.clope.net 5.2.1-RELEASE-p1 FreeBSD 
5.2.1-RELEASE-p1 #0: Sun Mar  7 00:07:38 CET 2004 
root at mulet.clope.net:/usr/obj/usr/src/sys/MULET_KERNEL  i386

- timestamp of the www/firefox/Makefile : Feb 19 13:11 Makefile

- Problem : Firefox don't start. I installed it via the ports, i simply 
did a portupgrade -RraP after cvsup the ports tree. After that, when i'm 
trying to launch firefox, the process firefox-bin runs with 85% of cpu 
load... nothing appear, no window for browsing.
So i tried to come back to mozilla-firebird, i re-installed it with the 
package, but anyway it's now doing the same thing than firefox. It seems 
  to be a problem that appear with dependancies during my portupgrade -RraP.
I wanted a browser.. so i installed mozilla classic, i didn't want to 
spend time with compilation, so i installed the pacakge : 
mozilla-gtk2-1.6.a.tbz, and i did the same thing... I became nervous... 
and tried with no gtk2 : mozilla-1.6.a,1.tbz and it works ! So, seems to 
be a problem with the GTK2 library.

I discovered that my GTK1 and 2 failed to upgrade due to a configure 
error, i tried to force the install, in fact, glib wasn't up to date, I 
fixed it and reinstalled Firefox, but the same problem persists (for 
firebird still the same problem).

I Don't really understand from where it's coming, I hope this report can 
help you for debugging Firefox. I believe that the portupgrade -RraP did 
something bad with a dependancie of fire*

Here is my version of GTK1 and 2:
x11-toolkits/gtk12 (gtk-1.2.10_11)
x11-toolkits/gtk20 (gtk-2.2.4_2)

Alexandre Ahmim-Richard
passe at clope.net

More information about the freebsd-ports mailing list