Kent Stewart kstewart at
Mon Jun 14 20:45:52 GMT 2004

On Monday 14 June 2004 01:15 pm, Pat Lashley wrote:
> --On Monday, June 14, 2004 04:10:32 -0700 Kent Stewart 
<kstewart at> wrote:
> > I have probably processed at least 5-10K wus with the current
> > FreeBSD version of setiathome. The only time I have seen it do
> > something like this is when the files are owned by a different user
> > than the one running seti. It can run but not write to the state
> > file.
> I see the busy-but-not-updating state about once a week or so on all
> of my FreeBSD machines; but not Solaris or Mac OS X.
> When it happens to me, the file ownerships and permissions have not
> changed.  I have found that I don't have to abandon a work unit in
> progress though.  I just shut down the seti process(es); make sure
> they are gone; then delete the pid.sah and lock.sah files.  (If the
> state.sah is empty, I delete it too.)  Then restart using the rc
> script; and all is well.

This is interesting. I login as seti when I boot a system and run it 
from that users account. I also have my own run and update scripts. I 
never see the hang except when I have caused it. The caching scheme I 
use has a directory with the machine name and a number. Each wu is 
processed by the setiathome executable in that directory. I run it at a 
nice of 19 and that lets anything run that needs to. The only exception 
is on 5.x where it always consumes resources. If I am doing a system 
upgrade or a large portupgrade on 5.x, I kill the running seti process.

I have thought about running the linux-686 version which out produces 
the FreeBSD version by 25% or more but never got around to it. It 
didn't run when I tried it and I wasn't going to add some of the linux 
capability just to run setiathome.

Kent Stewart
Richland, WA

More information about the freebsd-ports mailing list