qtorrent build error

epilogue at allstream.net epilogue at allstream.net
Sat Jun 12 07:39:59 GMT 2004

On Fri, 11 Jun 2004 14:27:12 -0700
Kris Kennaway <kris at obsecurity.org> wrote:

> On Fri, Jun 11, 2004 at 05:14:48PM -0400, epilogue at allstream.net wrote:
> > hello all,
> > 
> > got this error while trying to build qtorrent.
> > 
> > # make
> > ===>
> > ===> For qtorrent to work you need to compile
> > ===> python WITH_THREADS defined, it is default
> Verify this ^^^
> Kris

hello again Kris,

well, i wasn't sure how to determine whether my installed version of python
(2.3.3_5) had been built with threads ('man python' didn't yield anything
helpful).  because 'with threads' is the default setting in the python
Makefile, i presume it had been, but i decided nevertheless to
portupgrade to the latest and greatest version (2.3.4) simply for good

tried rebuilding, no dice.

while reading the qtorrent Makefile, i noted the build/run dependencies are
upon py-qt not 'vanilla' python.  though the py-qt Makefile makes no
mention of valid build switches, i decided to rebuild it and define
'--WITH_THREADS=yes'.  no error messages.  either the switch worked
or it was ignored.

well, i'm not sure if it was portupgrading python or the 'with threads'
switch on py-qt, but the good news is that qtorrent now builds and

i should probably have managed to figure this one out solo, but was
a little confused by the error message which suggested compiling python
with 'default' settings -- how mine must have been installed (unless
the port, which originally installed python as a dependency, set something
other than default).  anyhow, thanks for nudging me in the right direction.


More information about the freebsd-ports mailing list