xterm in X.org error with some locales?

Jie Gao gaoj at cpsc.ucalgary.ca
Mon Jul 26 10:54:52 PDT 2004

I did know about the luit thing. And I also tried to give luit a setuid 
permission and start xterm again. But still the same. The xterm window 
disappeared immediately after it showed up.

I remember when I was using XFree86 without a setuid luit, I only got a 
warning message in the new xterm window. But now with Xorg, the problem is 
I can never have an xterm window for more than a second.

On July 26, 2004 03:07 am, Eric Anholt wrote:
> On Sun, 2004-07-25 at 20:41, Jie Gao wrote:
> > Hi, all
> >
> > I switched to Xorg on 5-CURRENT yesterday, following the steps in
> > /usr/ports/UPDATING and portupgraded everything. Everything works just
> > fine except one thing: xterm has some error on some particular locales.
> > The symptom is like this:
> >
> >   # setenv LANG zh_CN.eucCN
> >   # xterm
> >
> > After this, xterm's window only quickly flashed out and then
> > disappeared. I tried various locales, mainly zh_CN.* ones, finding that
> > zh_CN.eucCN, zh_CN.GB2312 and zh_CN.GBK all make xterm a splash.
> >
> > I cannot tell what's wrong because I can find corresponding error
> > information nowhere. I checked console, /var/log/messages,
> > ~/.xsession-error and /var/log/Xorg.0.log. None of them contain
> > relevant messages.
> I can't remember for sure, but I think this was part of the issue, which
> is printed when you build -clients:
> > If you want to use xterm with locales in a secure manner, luit must be
> installed
> > setuid.  If you want to do this, hit Ctrl-C now and use "make

More information about the freebsd-ports mailing list