Problem with win32-codecs 2.0.99

Dwayne MacKinnon dmk at
Sat Jul 24 09:22:47 PDT 2004


I'm running MPlayer 1.0pre4-2.95.4 on FreeBSD 4.10-RELEASE. After upgrading 
the win32-codecs port I discovered that the audio on my Quicktime files would 
no longer work. The following is the audio output when I tried to play a 
Quicktime Spider-Man 2 trailer that worked fine before the upgrade.

Opening audio decoder: [qtaudio] QuickTime Audio Decoder
External func OLEPRO32.DLL:254
External func COMCTL32.dll:17
External func COMCTL32.dll:16
External func OLEAUT32.dll:8
External func OLEAUT32.dll:10
External func OLEAUT32.dll:4
External func OLEAUT32.dll:2
External func OLEAUT32.dll:149
External func OLEAUT32.dll:7
External func WS2_32.dll:9
External func WS2_32.dll:21
External func WS2_32.dll:17
External func WS2_32.dll:20
External func WS2_32.dll:115
External func WS2_32.dll:116
External func WS2_32.dll:10
External func WS2_32.dll:23
External func WS2_32.dll:6
External func WS2_32.dll:2
External func WS2_32.dll:1
External func WS2_32.dll:151
External func WS2_32.dll:18
External func WS2_32.dll:16
External func WS2_32.dll:19
External func WS2_32.dll:5
External func WS2_32.dll:7
External func WS2_32.dll:8
External func WS2_32.dll:4
External func WS2_32.dll:3
External func WS2_32.dll:13
Unsupported QuickTime version (0x6697c5c0)
ADecoder preinit failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x324D4451.
Read DOCS/HTML/en/codecs.html!

As I still had the dist files for the older version of the win32-codecs port, 
I manually replaced the qt65dlls-20040704 files with the older qt6dlls files. 
At that point I tried the trailer again, and it worked perfectly. For 
comparison purposes, here's the output from the successful try.

Opening audio decoder: [qtaudio] QuickTime Audio Decoder
External func COMCTL32.dll:17
External func COMCTL32.dll:16
QuickTime6 DLLs found
QuickTime.qts patched!!! old entry=0x6693b330
theQuickTimeDispatcher catched -> 0x6693b330
WARNING! Invalid Ptr handle!

### Searching for QuickTime plugins (*.qtx) at /usr/local/lib/win32...
### FindNext: 3ivX.qtx
### FindNext: AvidQTAVUICodec.qtx
### FindNext: BeHereiVideo.qtx
### FindNext: Indeo4.qtx
### FindNext: On2_VP3.qtx
### FindNext: QuickTimeEssentials.qtx
### FindNext: QuickTimeInternetExtras.qtx
### FindNext: ZyGoVideo.qtx
theQuickTimeDispatcher catched -> 0x6693b330
theQuickTimeDispatcher catched -> 0x6693b330
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 15999->176400 (128.0 kbit)
Selected audio codec: [qdmc] afm:qtaudio (Quicktime QDMC/QDM2 audio decoders)

I suspect that it's possible that /usr/local/share/mplayer/codecs.conf needs 
to be updated somehow to work with the newer qt65dlls files. However, I don't 
know too much about how mplayer reads codecs and finds the right ones, so I'm 
not sure. 

I can't afford to make exceptions. I mean, once word leaks out that a pirate 
has gone soft, people begin to disobey you and then it's nothing but work, 
work, work all the time. -The Dread Pirate Roberts, from The Princess Bride

More information about the freebsd-ports mailing list