Ports database somehow munged on one of my machines: undefined method `each'

Tillman Hodgson tillman at seekingfire.com
Mon Jul 12 11:50:01 PDT 2004

Howdy folks,

On a low-end i386 -STABLE machine I administer I recently ran into a
ports problem:

[root at pluto ~]# portversion -vL=
bsdiff-4.1                  <  needs updating (port has 4.2)
libiconv-1.9.1_3            <  needs updating (port has 1.9.2)
pkg_install-devel-20040623  <  needs updating (port has 20040629)
portaudit-0.4.1             <  needs updating (port has 0.5)
portupgrade-20040701        <  needs updating (port has 20040701_2)

[root at pluto ~]# portupgrade bsdiff
--->  Upgrading 'bsdiff-4.1' to 'bsdiff-4.2' (misc/bsdiff)
--->  Building '/usr/ports/misc/bsdiff'
===>  Cleaning for bsdiff-4.2
>> bsdiff-4.2.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
>> Attempting to fetch from http://www.daemonology.net/bsdiff/.
bsdiff-4.2.tar.gz                             100% of 7686  B   42 kBps
===>  Extracting for bsdiff-4.2
>> Checksum OK for bsdiff-4.2.tar.gz.
===>  Patching for bsdiff-4.2
===>  Configuring for bsdiff-4.2
===>  Building for bsdiff-4.2
cc -O -pipe -march=pentium -O3  bsdiff.c  -o bsdiff
cc -O -pipe -march=pentium -O3  bspatch.c  -o bspatch
--->  Backing up the old version
--->  Uninstalling the old version
--->  Deinstalling 'bsdiff-4.1'
** Listing the failed packages (*:skipped / !:failed)
        ! bsdiff-4.1    (undefined method `each' for nil:NilClass)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
** Listing the failed packages (*:skipped / !:failed)
        ! misc/bsdiff (bsdiff-4.1)      (uninstall error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

All ports that I attempt to upgrade bomb out with this same error.

Interestingy, the ports tree is NFS shared and other machines using the
same export are behaving normally.

I've tried `pkgdb -Ffu` without success. It looks to me (untutored in
the inner workings of the port system) more like an infrastructure
problem than a database problem. I've looked through CHANGES and
UPDATING and there didn't appear to anything that would relate to this

Thanks for your help,


Page 38: Be sure that, in the excitement of creating a totally rad
password, you resist the temptation to tell someone just to show off how
smart you are.
	- Harley Hahn, _The Unix Companion_

More information about the freebsd-ports mailing list