upgrading gswitchit-2.5.0_2 to 2.5.0_3 broken?

Timur I. Bakeyev timur at com.bat.ru
Thu Jan 29 08:46:42 PST 2004


In general, API changes were made in favour of the upcoming Gnome 2.6, 
which will include functionality of the gswitchit_applet natively. So, the
proper way, probably, would be to mark libxklavier-0.97 as a devel version
and stick with the 0.96 as the one, which gswitchit uses.

With regards,
	    Timur.

On Thu, Jan 29, 2004 at 10:04:39AM -0500, Joe Marcus Clarke wrote:
> On Thu, 2004-01-29 at 07:50, Troy wrote:
> > Just was trying to portupgrade gswitchit and ran into these errors?
> > Anyone have an idea why?
> 
> The new libxklavier broke it.  I'm trying to find out if there will be a
> new gswitchit that handles the API changes.
> 
> > gswitchit_config.c : 348 :  too many arguments to function
> > `XklConfigWriteXKMFile'
> > gmake[2]: *** [gswitchit_config.lo] Error 1
> > gmake[2]: Leaving directory
> > `/usr/ports/x11/gswitchit/work/gswitchit-2.5.0/common'
> > gmake[1]: *** [all-recursive] Error 1
> > gmake[1]: Leaving directory
> > `/usr/ports/x11/gswitchit/work/gswitchit-2.5.0'
> > gmake: *** [all] Error 2
> > *** Error code 2
> > 
> > Stop in /usr/ports/x11/gswitchit.
> > ** Command failed [exit code 1]: /usr/bin/script -qa
> > /tmp/portupgrade45753.0 make
> > ** Fix the problem and try again.
> > ** The following packages were not installed or upgraded (*:skipped /
> > !:failed)
> >         ! x11/gswitchit (gswitchit-2.5.0_2)     (compiler error)


More information about the freebsd-ports mailing list