openssh-portable 3.7.1p2

Jim Bartlett jbartlett at
Sun Jan 18 12:03:01 PST 2004

I am currently running openssh-portable 3.6.1p1 on FreeBSD 5.1 on i386. I
extracted the new port (3.7.1p2) and tried to run 'portupgrade -v' on it. I
get a patch error. Patch "patch-auth2-chall.c" fails to apply cleanly.
That's it.

I have tried deinstalling the old port, make clean, etc and to no avail,
same error. Part of portupgrade output below:

--->  Upgrading 'openssh-portable-3.6.1p2' to 'openssh-portable-3.7.1p2'
--->  Build of security/openssh-portable started at: Sun, 18 Jan 2004
15:08:24 -0500
--->  Building '/usr/ports/security/openssh-portable'
===>  Cleaning for perl-5.6.1_15
===>  Cleaning for openssh-portable-3.7.1p2
===>  Extracting for openssh-portable-3.7.1p2
>> Checksum OK for openssh-3.7.1p2.tar.gz.
===>  Patching for openssh-portable-3.7.1p2
===>  Applying extra patch
===>  Applying FreeBSD patches for openssh-portable-3.7.1p2
3 out of 3 hunks failed--saving rejects to auth2-chall.c.rej
>> Patch patch-auth2-chall.c failed to apply cleanly.
>> Patch(es) patch-auth.c patch-auth1.c applied cleanly.
*** Error code 1

Stop in /usr/ports/security/openssh-portable.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade17452.0
** Fix the problem and try again.

Any ideas? Thanks for any info.

More information about the freebsd-ports mailing list