No subject

Nick Fennell nick.fennell at
Fri Jan 16 06:03:05 PST 2004


Tried to install Linux compatabilty which i was told could be done via ports ( /usr/ports/emulation/linux-base)

My system is a Pentium 3 933mhz with 1024mb SD 133mhz ram, No SSCI and im running FreeBSD4.9

To start i ran the following command

species-8472# make clean install

echo'd the following

===>  Cleaning for rpm-3.0.6_8
===>  Cleaning for libiconv-1.9.1_3
===>  Cleaning for autoconf-2.13.000227_5
===>  Cleaning for automake-1.4.5_9
===>  Cleaning for gettext-0.12.1
===>  Cleaning for gmake-3.80_1
===>  Cleaning for libtool-1.3.5_1
===>  Cleaning for m4-1.4_1
===>  Cleaning for popt-1.6.4_1
===>  Cleaning for pkg_install-20030714_1
===>  Cleaning for expat-1.95.6_1
===>  Cleaning for sed_inplace-2002.10.19
===>  Cleaning for linux_base-7.1_5
===>  Extracting for linux_base-7.1_5
>> Checksum OK for rpm/redhat-release-7.1-1.noarch.rpm.
>> Checksum OK for rpm/setup-2.4.7-1.noarch.rpm.
>> Checksum OK for rpm/filesystem-2.0.7-1.noarch.rpm.
>> Checksum OK for rpm/basesystem-7.0-2.noarch.rpm.
>> Checksum OK for rpm/termcap-11.0.1-8.noarch.rpm.
>> Checksum OK for rpm/db1-1.85-5.i386.rpm.
>> Checksum OK for rpm/db3-3.1.17-7.i386.rpm.
>> Checksum OK for rpm/gdbm-1.8.0-5.i386.rpm.
>> Checksum OK for rpm/glib-1.2.9-1.i386.rpm.
>> Checksum OK for rpm/libtermcap-2.0.8-26.i386.rpm.
>> Checksum OK for rpm/bash-2.04-21.i386.rpm.
>> Checksum OK for rpm/bzip2-1.0.1-3.i386.rpm.
>> Checksum OK for rpm/compat-libstdc++-6.2-
>> Checksum OK for rpm/ncurses-5.2-8.i386.rpm.
>> Checksum OK for rpm/info-4.0-20.i386.rpm.
>> Checksum OK for rpm/fileutils-4.0.36-4.i386.rpm.
>> Checksum OK for rpm/grep-2.4.2-5.i386.rpm.
>> Checksum OK for rpm/popt-1.6.2-8.i386.rpm.
>> Checksum OK for rpm/readline-4.1-9.i386.rpm.
>> Checksum OK for rpm/setserial-2.17-2.i386.rpm.
>> Checksum OK for rpm/slang-1.4.2-2.i386.rpm.
>> Checksum OK for rpm/sh-utils-2.0-13.i386.rpm.
>> Checksum OK for rpm/rpm-4.0.2-8.i386.rpm.
>> Checksum OK for rpm/freetype-2.0.1-4.i386.rpm.
>> Checksum OK for rpm/glibc-common-2.2.4-32.i386.rpm.
>> Checksum OK for rpm/glibc-2.2.4-32.i386.rpm.
>> Checksum OK for rpm/XFree86-libs-4.1.0-49.i386.rpm.
>> Checksum OK for rpm/zlib-1.1.4-8.7x.i386.rpm.
>> Checksum OK for rpm/libstdc++-2.96-112.7.1.i386.rpm.
===>  Patching for linux_base-7.1_5
===>   linux_base-7.1_5 depends on executable: rpm - not found
===>    Verifying install for rpm in /usr/ports/archivers/rpm
===>  Extracting for rpm-3.0.6_8
>> Checksum OK for rpm-3.0.6.tar.gz.
===>  Patching for rpm-3.0.6_8
===>   rpm-3.0.6_8 depends on file: /usr/local/bin/sed_inplace - found
===>  Applying FreeBSD patches for rpm-3.0.6_8
===>   rpm-3.0.6_8 depends on executable: gmake - found
===>   rpm-3.0.6_8 depends on file: /usr/local/libexec/automake14/automake - found
===>   rpm-3.0.6_8 depends on file: /usr/local/libexec/autoconf213/autoconf - found
===>   rpm-3.0.6_8 depends on file: /usr/local/libexec/libtool13/libtool - found
===>   rpm-3.0.6_8 depends on file: /usr/local/sbin/pkg_info - found
===>   rpm-3.0.6_8 depends on shared library: intl.5 - found
===>   rpm-3.0.6_8 depends on shared library: popt.0 - found
===>  Configuring for rpm-3.0.6_8
creating cache ./config.cache
checking host system type... i386-portbld-freebsd4.5
checking target system type... i386-portbld-freebsd4.5
checking build system type... i386-portbld-freebsd4.5
checking for a BSD compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking whether gmake sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... found
checking for gcc... cc
checking whether the C compiler (cc -O -pipe  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
===>  Script "configure" failed unexpectedly.
      Please report the problem to ports at [maintainer] and attach
      the "/usr/ports/archivers/rpm/work/rpm-3.0.6/config.log" including the
      output of the failure of your make command. Also, it might be a good
      idea to provide an overview of all packages installed on your system
      (e.g. an `ls /var/db/pkg`).
*** Error code 1

Stop in /usr/ports/archivers/rpm.
*** Error code 1

Stop in /usr/ports/emulators/linux_base.

This is the config.log file from the /usr/ports/emulaton/linux-base/work

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:605: checking host system type
configure:626: checking target system type
configure:644: checking build system type
configure:679: checking for a BSD compatible install
configure:732: checking whether build environment is sane
configure:789: checking whether gmake sets ${MAKE}
configure:835: checking for working aclocal
configure:848: checking for working autoconf
configure:861: checking for working automake
configure:874: checking for working autoheader
configure:887: checking for working makeinfo
configure:932: checking for gcc
configure:1045: checking whether the C compiler (cc -O -pipe  ) works
configure:1061: cc -o conftest -O -pipe  -I/usr/local/include  conftest.c -L/usr/local/lib -lintl -liconv 1>&5
/usr/libexec/elf/ld: cannot find -liconv
configure: failed program was:

#line 1056 "configure"
#include "confdefs.h"


And finally this is the package list off my machine

species-8472# ls /var/db/pkg

Xaw3d-1.5                       jpeg-6b_1                       p5-Image-Info-1.12              png-1.2.5_3
apache-1.3.29_1                 libiconv-1.9.1_3                p5-MIME-Base64-2.22             popt-1.6.4_1
autoconf-2.13.000227_5          libtool-1.3.4_2                 p5-Mysql-modules-1.2219         portupgrade-20030723
automake-1.4.5_9                libtool-1.3.5_1                 p5-Net-Daemon-0.38              postfix-,2
bash-2.05b.007                  libtool-1.4.3_2                 p5-PlRPC-0.2016                 proftpd-1.2.4
bison-1.75_1                    linux_base-6.1                  p5-ReadLine-Perl-1.0203         profxp-3p2
bnc-2.8.4                       m4-1.4_1                        p5-SOCKS-0.03                   psybnc-2.3.1
cclient-2002d,1                 mod_php4-4.3.4_4,1              p5-Storable-2.08                ruby-
cvsup-without-gui-16.1h         mysql-client-3.23.58            p5-Term-ANSIColor-1.07          ruby-bdb1-0.2.1
dcc-2.5.6_1                     mysql-server-3.23.47            p5-Term-ReadKey-2.21            ruby-shim-ruby18-1.8.1.p3
expat-1.95.6_1                  netpbm-10.19_3                  p5-Time-HiRes-1.52,1            screen-4.0.1_2
freetype2-2.1.5_1               openssl-0.9.7c                  p5-URI-1.29                     sed_inplace-2002.10.19
gettext-0.10.35_1     ,1                p5-XML-Parser-2.34              tcl-8.3.5_2
gettext-0.12.1                  p5-Compress-Zlib-1.32           p5-XML-Simple-2.09              tcl-8.4.5,1
gmake-3.80_1                    p5-DBI-1.20                     pcre-4.4                        tcltls-1.4.1
iconv-2.0_3                     p5-Data-ShowTable-3.3           pine-4.58                       tcsh-6.11.00
ispell-3.2.06_4                 p5-File-Spec-0.86               pkg_install-20030714_1          tiff-3.6.1
jbigkit-1.5                     p5-IO-String-1.02               pkgdb.db

More information about the freebsd-ports mailing list