mod_perl?

Ben Laurie ben at algroup.co.uk
Fri Jan 9 10:58:16 PST 2004


So, if you try to install (using CPAN) Apache::Request after installing 
the mod_perl port, it doesn't work at all. The reason appears to be that 
all the mod_perl bits get installed in site_perl/5.8.0, but what's 
actually running is 5.8.2, so that directory isn't searched.

AFAICS working around this by using PERL5LIB and the like is fraught 
with danger, because it will then include 5.8.0 stuff in preference to 
5.8.2 stuff, which is obviously ungood.

Am I missing something obvious?

Cheers,

Ben.

-- 
http://www.apache-ssl.org/ben.html       http://www.thebunker.net/

"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff



More information about the freebsd-ports mailing list