follow-up Re: I'm having an awful time updating gdm2 and other ports

Paul Seniura aka UDSD387 pdseniura at techie.com
Tue Jan 6 11:50:51 PST 2004


> Any time you run "use.perl", do "env FORCE_PKG_REGISTER=1 portupgrade -f
> p5-\*".

Ah, thank you for reminding me --
that was going to be my last-ditch effort,
install all the p5-* ports to kingdom-come.  ;)
Guess I'll go git it running...

> (I consider the need for the FORCE_PKG_REGISTER thing a bug, but don't
> know how to get around it.  The problem appears to be that portupgrade
> doesn't actually upgrade them in dependency order, so the upgrade tends
> to lose when some module forces install of another, which discovers that
> it's "already installed" and aborts.)

Of course one other way of 'fixing' this has come to mind:
Have FreeBSD install perl-5.8.x as its 'system' instead of 5.6.x.  ;)


Now that Steve Jobs is thru with his spiel, the Internet ought to be
un-clogged so we can grab all those p5 things.  ;)


Thank you again,

  --  Paul Seniura
      System Specialist
      State of Okla. D.O.T.



More information about the freebsd-ports mailing list