ruby in malloc(): error: allocation failed Abort (core dumped)

Edwin Culp eculp at
Wed Feb 11 10:18:49 PST 2004

Quoting Kris Kennaway <kris at>:

> On Wed, Feb 11, 2004 at 06:28:19AM -0600, Edwin Culp wrote:
>> This error seems to be part of the threading issue or was brought to 
>> light by
>> it.
>> First I'm running current as of yesterday, while doing a portupgrade -Rrua
>> during the rebuild of portupgrade.  I tried to get past it by recompiling
>> qmake, etc. with no luck so I added a /etc/libmap.conf based on the 
>> man page,
>> recompiled everything based other's information on the mailling 
>> list.  I even
>> blew away my ports tree, distfiles, etc and resuped all.  Everything is/was
>> working except portupgrade/ruby.  When I start portupgrade or friends, I get
>> the above malloc message and signal 6 from ruby.
>> --->  Session started at: Wed, 11 Feb 2004 06:02:56 -0600
>> [Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 301 
>> packages found
>> (-26 +17) (...)ruby in malloc(): error: allocation failed
>> Abort (core dumped)
>> Any suggestions would be highly appreciated.  I'm blocked.
> I ran into this and fixed it by removing /var/db/pkg/pkgdb.db.  This
> file had become corrupt (perhaps because ruby and the ruby modules
> were linked against conflicting thread libraries), but recompiling
> ruby* from scratch did not allow pkgdb to fix the file.  This is
> probably a bug in pkgdb.

Kris,  ! F A N T A S T I C !  That was it.  It works fine :-)  I don't think I
would have ever found it, I was looking everywhere else.  Of course, thanks to
this I now have a un planed, pristin and empty ports and package tree but it
was time.

Thanks so much for sharing,


More information about the freebsd-ports mailing list