qt-3.2.3 fails during configure, looking for qplatformdefs.h in wrong prefix?

Fish fish at fish-mail.com
Tue Feb 10 20:23:57 PST 2004


I'm sure I've done something wrong, but I can't seem to put my finger on
it.  I set up a libmap.conf, and I ran portupgrade -f XFree86-libraries
qmake, and then when I then ran portupgrade -fR qt-3.2.3 I get the
following.

Script started on Tue Feb 10 23:16:26 2004
bash-2.05b# portupgrade -f qt-3.2.332-3.2.3
--->  Reinstalling 'qt-3.2.3' (x11-toolkits/qt32)
--->  Building '/usr/ports/x11-toolkits/qt32'
===>  Cleaning for libiconv-1.9.1_3
===>  Cleaning for gettext-0.13.1
===>  Cleaning for gmake-3.80_2
===>  Cleaning for imake-4.3.0_2
===>  Cleaning for libtool-1.3.5_1
===>  Cleaning for pkgconfig-0.15.0_1
===>  Cleaning for qmake-3.2.3_1
===>  Cleaning for jpeg-6b_1
===>  Cleaning for lcms-1.09_1,1
===>  Cleaning for libmng-1.0.5_1
===>  Cleaning for png-1.2.5_3
===>  Cleaning for tiff-3.6.1_1
===>  Cleaning for perl-5.6.1_15
===>  Cleaning for cups-base-1.1.20.0
===>  Cleaning for freetype2-2.1.5_2
===>  Cleaning for expat-1.95.6_1
===>  Cleaning for Xft-2.1.2_1
===>  Cleaning for fontconfig-2.2.90_4
===>  Cleaning for XFree86-libraries-4.3.0_6
===>  Cleaning for qt-3.2.3

===> **************************************************
===> If you do not want to build QT with XFT support 
===> press Ctrl-C and set WITHOUT_XFT
===> **************************************************
===>  Vulnerability check disabled
===>  Extracting for qt-3.2.3
>> Checksum OK for KDE/qt-x11-free-3.2.3.tar.bz2.
===>  Patching for qt-3.2.3
===>  Applying FreeBSD patches for qt-3.2.3
===>   qt-3.2.3 depends on executable: qmake - found
===>   qt-3.2.3 depends on shared library: mng.1 - found
===>   qt-3.2.3 depends on shared library: png.5 - found
===>   qt-3.2.3 depends on shared library: jpeg.9 - found
===>   qt-3.2.3 depends on shared library: Xft.2 - found
===>   qt-3.2.3 depends on shared library: cups.2 - found
===>   qt-3.2.3 depends on shared library: X11.6 - found
===>  Configuring for qt-3.2.3

   The specified system/compiler port is not complete:

   	/usr/X11R6/share/qt/mkspecs/freebsd-g++/qplatformdefs.h

   Please contact qt-bugs at trolltech.com.

===>  Script "configure" failed unexpectedly.
Please report the problem to kde at FreeBSD.org [maintainer] and attach the
"/usr/ports/x11-toolkits/qt32/work/qt-x11-free-3.2.3/config.log"
including
the output of the failure of your make command. Also, it might be a good
idea
to provide an overview of all packages installed on your system (e.g. an
`ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/x11-toolkits/qt32.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade65110.0 make
** Fix the problem and try again.
** The following packages were not installed or upgraded (*:skipped /
!:failed)
	! x11-toolkits/qt32 (qt-3.2.3)	(unknown build error)

The odd thing is, the file it's complaining about isn't in
/usr/X11R6/share, it's in /usr/local/share.  Did my environment get
sporked somewhere along the way, am I doing something wrong, or is there
a problem with the port?  Oh, and the config.log file it's asking me to
send doesn't exist, either.

Thanks for your help,

Fish



More information about the freebsd-ports mailing list