compile failure on trm-0.2.1

Kent Stewart kstewart at owt.com
Mon Feb 9 17:10:46 PST 2004


On Monday 09 February 2004 04:45 pm, ebroh wrote:
> To whom it may concern.
>
> I have little problem with updating "trm-0.2.1"
>
> checking for mb_GetVersion in -lmusicbrainz... yes
> checking "for version >= 2.0.0 in -lmusicbrainz"... "no"
> *
> *  Version 2.0.0 or higher of the MusicBrainz
> *  client library needs to be installed to build this application.
> *  Please download the library from:
> *  http://www.musicbrainz.org/download
> *
> configure: error: "Cannot build. Stop."
> ===>  Script "configure" failed unexpectedly.
> Please report the problem to ports at FreeBSD.org [maintainer] and
> attach the "/usr/ports/audio/trm/work/trm-0.2.1/config.log" including
> the output of the failure of your make command. Also, it might be a
> good idea to provide an overview of all packages installed on your
> system (e.g. an `ls /var/db/pkg`). *** Error code 1
>
> Stop in /usr/ports/audio/trm.

I forgot to add that the conflict is between libmusicbrainz and 
musicbrainz. After you delete musicbrainz, you will have to rebuild 
libmusicbrainz. Then, you should be able to build trm.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html


More information about the freebsd-ports mailing list