setting autoconf version?

Liam Foy liamfoy at
Sat Feb 7 07:41:55 PST 2004

Louis Munro (by way of Louis Munro <louismunro at>) wrote:

>Hello all of you,
>I'm installing KDE 3.2 from ports and I get this (see below).
>It seems to say that I don't have the right version of autoconf, but I just
>installed all of them from ports (2.53_1 & 2.57_1) and that doesn't make any
>difference. I still get the same error message.
>How do I tell make which version of autoconf to use?
>I run 4.9 stable...
>(output from make install)
>===>  Installing for kde-3.2.0
>===>   kde-3.2.0 depends on executable: kjumpingcube - found
>===>   kde-3.2.0 depends on executable: kppp - found
>===>   kde-3.2.0 depends on executable: kview - found
>===>   kde-3.2.0 depends on executable: kmix - found
>===>   kde-3.2.0 depends on executable: kdevelop - not found
>===>    Verifying install for kdevelop in /usr/ports/devel/kdevelop
>===>  Building for kdevelop-3.0.0
>cd . && rm -f configure
>cd . && gmake -f admin/Makefile.common configure
>gmake[1]: Entering directory `/usr/ports/devel/kdevelop/work/kdevelop-3.0.0'
>aclocal.m4:11884: error: Autoconf version 2.54 or higher is required
>aclocal.m4:11884: the top level
>gmake[1]: *** [configure] Error 1
>gmake[1]: Leaving directory `/usr/ports/devel/kdevelop/work/kdevelop-3.0.0'
>gmake: *** [configure] Error 2
>*** Error code 2
>Stop in /usr/ports/devel/kdevelop.
>*** Error code 1
>Stop in /usr/ports/x11/kde3.
>freebsd-ports at mailing list
>To unsubscribe, send any mail to "freebsd-ports-unsubscribe at"
You need autoconf 2.54 or higher like it states. Grap the latest port 
which is...

cd /usr/ports/devel/autoconf257 && make all install clean distclean

install it, and then attempt to install kde3 again.

-Liam Foy

More information about the freebsd-ports mailing list