Missing SSL support in core php4

Michael Ranner mranner at inode.at
Sun Aug 29 03:36:02 PDT 2004


Hello!

First it was a great idea to build PHP extensions from different ports like 
NetBSD's pkgsrc does. But it seems, thhat one thing was overseen:

If you build the OpenSSL extension completely not with the main PHP build, you 
have no SSL support in some of the core functions like "fsockopen". Therefore 
it's not possible to use the squirrelmail port with SSL or TLS support to 
connect with cyrus imap or other IMAP/POP3 server software.

So I did search for an acceptable solution, but it seems to need some further 
hacking:

If you build PHP4 with "--with-openssl=${OPENSSLBASE}" you will have SSL 
support in core functions but also PGP includes the static OpenSSL extension 
which conflicts with the php4-openssl port.

Now I tried to build PHP4 with "--with-openssl=shared,${OPENSSLBASE}", you 
have SSL support in core functions, but you have to prevent PHP4 from 
installung the shared extension, because its not listed in pkg-plist and/or 
conflicts with the php4-openssl port.

I have not found any option to include only SSL support in the core functions 
and not build the openssl extension in PHP's configure script.

Regards

-- 
/\/\ichael Ranner

mranner at inode.at - mranner at jawa.at - mranner at bugat.at
-----------------------------------------------------
   BSD Usergroup Austria - http://www.bugat.at/

-----BEGIN GEEK CODE BLOCK-----
GIT/CS/AT dx(-) s+:(++:) a- C++ UBLVS++++$ P++>+++$ L-(+)$ E---
W+++$ N+(++) o-- K- w--()$ O-(--) M@ V-(--) PS+>++ PE(-) Y+ PGP(-)
t+ 5+ X+++(++++) R* tv++ b+(++) DI++ D-(--) G- e h--(*) r++ y?
------END GEEK CODE BLOCK------


More information about the freebsd-ports mailing list