portupgrade having problems bootstrapping new ports?

Daniel Eischen deischen at freebsd.org
Sat Aug 28 15:29:33 PDT 2004

On Sat, 28 Aug 2004, Michael Nottebrock wrote:

> On Friday 27 August 2004 20:31, Brandon D. Valentine wrote:
> > On Fri, Aug 27, 2004 at 02:21:48PM -0400, Daniel Eischen wrote:
> > > No matter what I tried, 'portupgrade -NR net/samba3' did
> > > nothing.  It went off and thought for a bit, then came back
> > > with the prompt -- no errors.  I tried net/samba (samba-2.x)
> > > and that worked.  After I manually built and installed
> > > samba3, 'portupgrade -fNR net/samba3' worked.
> >
> > I have seen portupgrade behave this way in the past and everytime it
> > happens to me I find I have an out of date ports INDEX.
> At the moment, you're getting an outdated INDEX with every cvsup. I recently
> raised this issue on another mailing list - hopefully it will be resolved
> soon.

Yes, that was the problem.  I had expected the INDEX to be
relatively up-to-date.  I had also thought samba3 had been
around for quite some time and it didn't occur to me that
it wouldn't be in the index.  Hmm, I just realized it
was samba-devel prior to samba3.


More information about the freebsd-ports mailing list