sysutils/bpm fails to notice that portupgrade is already installed

Oliver Eikemeier eikemeier at
Fri Aug 27 12:07:11 PDT 2004

Adam Weinberger wrote:

> But, in the meantime, if there is a significant cross-section of users
> who won't be able to use the bpm port, I would rather change the
> dependency line to make things Just Work. I haven't heard of the problem
> from anybody other than Dan, and I don't know whether it exists for
> others.

Feel free. Note that the problem should hit many other ports, like 
www/caudium12. Also, have you tried to *run* bpm without portupgrade in 
your $PATH? AFAICS bpm assumes to find portupgrade there (granted: I 
haven't tried, just looked at the source, so I may be wrong).

In my book, not having ${LOCALBASE}/sbin in your path is calling for 
trouble, since you assume that every binary that uses these tools have 
their path hardcoded. When you extend this to ${LOCALBASE}/bin, you will 
even exclude more binaries...


More information about the freebsd-ports mailing list