portupgrade having problems bootstrapping new ports?

Brandon D. Valentine brandon at dvalentine.com
Fri Aug 27 11:32:13 PDT 2004

On Fri, Aug 27, 2004 at 02:21:48PM -0400, Daniel Eischen wrote:
> No matter what I tried, 'portupgrade -NR net/samba3' did
> nothing.  It went off and thought for a bit, then came back
> with the prompt -- no errors.  I tried net/samba (samba-2.x)
> and that worked.  After I manually built and installed
> samba3, 'portupgrade -fNR net/samba3' worked.

I have seen portupgrade behave this way in the past and everytime it
happens to me I find I have an out of date ports INDEX.  This might seem
obvious, but I infrequently find the INDEX update slipping my mind.  If
you haven't already, you might try 'portsdb -uU' on that system and then
see if you can use portupgrade to build and install those ports.


Brandon D. Valentine
brandon at dvalentine.com                           http://www.geekpunk.net
Pseudo-Random Googlism:  summer is busiest season for emergency

More information about the freebsd-ports mailing list