tried everything (almost), keeps bombing -- Re: -Current build problems with audio/arts: "lt-mcopidl in free(): error: chunk is already free" and core dumped

Paul Seniura pdseniura at
Thu Aug 5 15:37:53 PDT 2004

I did 'ln -s aj /etc/malloc.conf' and even
set MALLOC_OPTIONS=aj -- and cleared them
both -- to no avail.

I also played with the original app's
Makefiles by prefixing each $(MCOPIDL)
line with an '@'.  Nope, an "abort trap"
is still too powerful.

The console & /var/log/messages are showing
this line every time, along with a core dump:

Aug  5 17:15:58 techpc04 kernel: pid 42813 (lt-mcopidl), uid 0: exited on signal 6 (core dumped)

The only thing I can think of is the system
isn't obeying these settings.  Instead it
seems as tho 'AJ' is hard-coded somewhere. 

I ran 'grep -inr "malloc_option"' under
/src/sys and elsewhere to see what/how it
is being used, and nothing showed up.

I will blow away /usr/obj and make a new
world & kernel with full cleaning, and set
MALLOC_OPTIONS=aj in /etc/make.conf just to
see if we can force those settings that way. 
No CTM delta is scheduled for quite a while,
so it will be this morning's snapshot still. 
It'll take an overnight run on this puny p2. 
Tomorrow I'll try building audio/arts again.

If this still fails, I feel the need to file
a bug report to fix the root of this
problem: a double 'free()' somewhere. 
And possibly explore why 5-current seems to
be ignoring malloc.conf settings as a
secondary issue.

  --  thx, Paul Seniura.

More information about the freebsd-ports mailing list