latest version of lsof still broke

Hermes Trismegistus hermes at
Sun Apr 18 21:17:44 PDT 2004

Thanks for the response, Abe, but still no love between my machine and the
latest port version of lsof. I just cvsup'ed in the last few minutes, and
I get the same results as earlier:

"In file included from ckkv.c:33:
../machine.h:54: error: syntax error before "cpumask_t"
../machine.h:54: warning: data definition has no type or storage class
*** Error code 1"

"** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! sysutils/lsof (lsof-4.71)     (bad C++ code)"

Again, the uname -a is:

FreeBSD 5.2-CURRENT FreeBSD 5.2-CURRENT #2: Wed
Mar 17 22:57:36 CST 2004
root at  i386

CFLAGS= -O -pipe

I have tried deinstalling the older version (lsof-4.71) . I have tried
"portupgrade -rR" and "pkg_add -r". All efforts to no avail. It is choking on
some "data definition" that is not associated with "type" or "storage class".
This is one for the port maintainer, Obrien. It may be that I am just
"shit out of luck" I even commented out "CPUTYPE?" in make.conf, and tried
again. Just no love...

Thank you

J. Craig Woods
UNIX/Linux Network/System Administration
Entropy requires no maintenance.

More information about the freebsd-ports mailing list