gaim linking problems

Mike Hunter mhunter at ack.Berkeley.EDU
Tue Apr 6 17:09:20 PDT 2004


On Apr 06, "Russell Jackson" wrote:

I had an offlist suggestion to do

portupgrade -rf glib-2\*.

Which is basically what you suggested, and I'm back in business.

Still curious about gdk vs gtk and .200 vs .400 stuff.

Thanks everybody,

Mike

> Gaim is linking to a version of your gnome libs other than the one that
> you have installed (or not install). I would recommend cvsuping your
> ports tree, remove all gnome libs, then reinstall them.
> 
> On Tue, Apr 06, 2004 at 11:36:04AM -0700, Mike Hunter wrote:
> > Hey everybody,
> > 
> > I'm still recovering from a bad gettext experience.  I'm trying to get gaim
> > back at this point.  It builds and installs, but bombs out at runtime with:
> > 
> > /libexec/ld-elf.so.1: Shared object "libgdk-x11-2.0.so.200" not found
> > 
> > Maybe I'm just new here, but what is the difference between libgdk and libgtk?
> > 
> > Here's lld `which gaim`...any thoughts what I am doing wrong?  Do I need to
> > update some build tools or something?  What does .200, .400 mean?


More information about the freebsd-ports mailing list