Problems with licq 1.2.7 on FreeBSD

Adam McLaurin adam.mclaurin at
Sat Apr 3 09:23:24 PST 2004

I'm having some real problems with licq lately. Let me try to describe
the sequence of events.

For 2 years licq has been running beautifully on my box, always with the
dock icon placed right in my Fluxbox slit so I can see from any
workspace if I have new messages. Then ...

One day there were some KDE upgrades, and all of a sudden the licq dock
icon stopped working properly. It started making it's own "mini-window"
(for lack of a better word) that was only on that one workspace (making
it useless).

Now, not all of my KDE ports were upgraded, so I thought maybe it was a
problem with compatibility. I was told the KDE stuff wouldn't compile
properly until I upgraded to FreeBSD-5.2.1 (I was on 5.1), so I sucked
it up and upgraded. 

Once on 5.2.1, all the KDE ports (kdelibs, kdebase, kdeartwork, etc)
compiled and installed beautifully. I tried recompiling licq and
licq-qt-gui; didn't help. In fact, it caused MORE problems ..

For some reason licq-qt-gui is no longer creating
/usr/local/lib/licq/ .. Instead, it creates
/usr/local/lib/licq/ .. Now, I can manually rename it so
that the daemon is happy, but it has no effect.

So I went on #licq on FreeNode IRC, and they blamed it on Fluxbox. So, I
upgraded my Fluxbox (now on 0.9.8), and no effect. The dock icon still
creates a little mini-window, titled 'Licq Wharf', that isn't in the
slit, and only appears on that one workspace.

I went by #fluxbox on FreeNode and got a chum there to install licq on
Fluxbox and it worked fine for him, however he was running Debian.

So, I'm out of ideas here. I need some other people to poke around on
this and see if they can reproduce the problem and try to identify a
common cause. I can't think of anything else to do here ...

If you want to troubleshoot this with me in real-time, I'm always in
#freebsd-gnome on FreeNode IRC. My nick there is 'irotas'.



"satyam, shivam, sundaram"

More information about the freebsd-ports mailing list