problems building several ports on fresh 4.9-PRERELEASE (x11, libbonobo)

Scott Reese sreese at codysbooks.com
Fri Sep 19 12:46:25 PDT 2003


On Fri, 19 Sep 2003 15:20:32 -0400
Joe Marcus Clarke <marcus at marcuscom.com> wrote:

> Use the following to upgrade to GNOME 2.4:

I'm not upgrading.  I'm installing it from scratch.  No previous Gnome installations on this system at all.  I just started putting this sytem together yesterday afternoon.  :)

> # pkgdb -F
> (answer yes to all prompts)

Finished with no prompts.

> # portupgrade ORBit2 libbonobo

Did nothing for ORBit2 and libbonobo was not installed and so gave "no matching package found" (the error in my previous message came from attempting to build and install libbonobo.  Again, no previous libbonobo installations are present)

> # portupgrade -rf -m BATCH=yes atk

Completed with no error messages

> # portupgrade -R -m BATCH=yes gnome2

"** No such package 'gnome2' is installed."

trying, instead, portinstall -R -m BATCH=yes gnome2:

[snip same error that was included in my previous message...]
pswrap: error in parsing dpsctrlops.psw
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-libraries/work/xc/lib/dps.
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-libraries/work/xc/lib.
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-libraries.
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-libraries.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall3621.8 make BATCH=yes reinstall
egrep: /var/db/pkg/XFree86-libraries-4.3.0_5/+CONTENTS: No such file or directory
--->  Restoring the old version
** Fix the installation problem and try again.
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 86 packages found (-0 +1) . done]
--->  Skipping 'x11-toolkits/gtk12' (gtk-1.2.10_10) because 'x11/XFree86-4-libraries' (XFree86-libraries-4.3.0_5) failed
--->  Skipping 'misc/gnomehier' (gnomehier-1.0_8) because 'x11/XFree86-4-libraries' (XFree86-libraries-4.3.0_5) failed
--->  Skipping 'misc/gnomemimedata' (gnomemimedata-2.4.0) because 'misc/gnomehier' (gnomehier-1.0_8) failed
--->  Skipping 'x11-fonts/Xft' (Xft-2.1.2) because 'x11/XFree86-4-libraries' (XFree86-libraries-4.3.0_5) failed
--->  Skipping 'x11/XFree86-4-clients' (XFree86-clients-4.3.0_2) because 'x11-fonts/Xft' (Xft-2.1.2) failed
--->  Skipping 'x11-fonts/XFree86-4-fontEncodings' (XFree86-fontEncodings-4.3.0) because 'x11/XFree86-4-libraries' (XFree86-libraries-4.3.0_5) failed
--->  Skipping 'x11-fonts/XFree86-4-fontScalable' (XFree86-fontScalable-4.3.0) because 'x11/XFree86-4-libraries' (XFree86-libraries-4.3.0_5) failed
--->  Skipping 'x11-toolkits/pango' (pango-1.2.5) because 'x11-fonts/XFree86-4-fontScalable' (XFree86-fontScalable-4.3.0) failed
--->  Skipping 'x11-toolkits/gtk20' (gtk-2.2.4) because 'x11-fonts/XFree86-4-fontScalable' (XFree86-fontScalable-4.3.0) failed
--->  Skipping 'devel/libglade2' (libglade2-2.0.1_1) because 'x11-fonts/XFree86-4-fontScalable' (XFree86-fontScalable-4.3.0) failed
--->  Skipping 'x11/gnome2' because 'devel/libglade2' failed
** The following packages were not installed or upgraded (*:skipped / !:failed)
        ! x11/XFree86-4-libraries (XFree86-libraries-4.3.0_5)   (install error)
        * x11-toolkits/gtk12 (gtk-1.2.10_10)
        * misc/gnomehier (gnomehier-1.0_8)
        * misc/gnomemimedata (gnomemimedata-2.4.0)
        * x11-fonts/Xft (Xft-2.1.2)
        * x11/XFree86-4-clients (XFree86-clients-4.3.0_2)
        * x11-fonts/XFree86-4-fontEncodings (XFree86-fontEncodings-4.3.0)
        * x11-fonts/XFree86-4-fontScalable (XFree86-fontScalable-4.3.0)
        * x11-toolkits/pango (pango-1.2.5)
        * x11-toolkits/gtk20 (gtk-2.2.4)
        * devel/libglade2 (libglade2-2.0.1_1)
        * x11/gnome2

Doesn't look very pretty...any further suggestions?

Thank you,
Scott


More information about the freebsd-ports mailing list