/usr/ports/graphics/py-opengl.

Frank Mayhar frank at exit.com
Sun Sep 7 19:25:52 PDT 2003


akriel wrote:
[ There is text before PGP section. ]
> Upon trying to install BITtorrent wich depends on py-opengl I came up
> with the following error but instad of python2.2 it was saying 2.3 for
> versions.
> 
> 
> copying build/Togl-1.5-tk8.4/Togl.so ->
> /usr/local/lib/python2.2/site-packages/OpenGL/Tk/freebsd4-tk8.4
> running "pkg_mkIndex
> /usr/local/lib/python2.2/site-packages/OpenGL/Tk/freebsd4-tk8.4 Togl.so"
> /usr/local/bin/tclsh8.4
> /usr/ports/graphics/py-opengl/work/PyOpenGL-2.0.0.44/register.tcl
> successful loading of Togl.so
> can't read "::tcl::direct": no such variable
>     while executing
> "if { !$::tcl::direct } {
>                     tclLog "commands provided were $cmds"
>                 }"
>     (procedure "pkg_mkIndex" line 281)
>     invoked from within
> "pkg_mkIndex -verbose
> /usr/local/lib/python2.2/site-packages/OpenGL/Tk/freebsd4-tk8.4 Togl.so"
>     (file
> "/usr/ports/graphics/py-opengl/work/PyOpenGL-2.0.0.44/register.tcl" line
> 1)
> *** Error code 1
>  
> Stop in /usr/ports/graphics/py-opengl.
> 
> I then edited makefile to see if using python 2.2 would work and it got
> the above error I have had many people from #freebsd on freenode attempt
> to correct this with me with no sucsess any help is apreciated.

You're using the wrong version of tcl.  When I ran into this, I had
multiple versions of tcl installed; removing all but the latest solved
the problem.
-- 
Frank Mayhar frank at exit.com	http://www.exit.com/
Exit Consulting                 http://www.gpsclock.com/
                                http://www.exit.com/blog/frank/


More information about the freebsd-ports mailing list