grip-3.1.2 still broken

Jesse Guardiani jesse at
Fri Oct 31 09:08:55 PST 2003

Kay Lehmann wrote:

> Jesse Guardiani schrieb:
>> Adam Weinberger wrote:


>> I think the grip port configures with --disable-cdpar for some reason,
>> so we can ignore:
>> - => /usr/local/lib/
>> Which leaves:
>> - => /usr/lib/
>> - => /usr/local/lib/
>> - => /usr/lib/
>> And I'm not too sure what those do.
> I can confirm that grip is working when compiled directly from source.
> But I compiled the port with cdparanoia-support and ldd gives no
> difference between port and direct compiled program. So I think Adams
> diff is just because of cdparanoia.

Actually, it's my diff; I'm Jesse. :)

I can confirm that here as well. If the grip port is built using:


Then this is the diff you get:

------ Begin diff output ------
--- /home/jesse/tmp/grip-sorted-src-ldd-output.txt      Thu Oct 30 12:53:31 2003
+++ /home/jesse/tmp/grip-sorted-port-ldd-output.txt     Fri Oct 31 11:17:50 2003
@@ -54,4 +54,4 @@ => /usr/X11R6/lib/ => /usr/local/lib/ => /usr/lib/
------ End diff output ------

> Unfortunatly I can't tell what's the
> exact problem. I tried to modify Makefile with various things diabled,
> but had no luck. My first thought was pthread since I had some problems
> with it with my own ports, but disabling corresponding flags did not
> help.

I tried compiling the source with what I think looks like what the port
is using:

    setenv CPPFLAGS "-I/usr/local/include -D_THREAD_SAFE"
    setenv LDFLAGS "-I/usr/local/lib -lc_r"
    gmake install

(I chose -lc_r because `/sbin/sysctl -n kern.osreldate` yields 501000,
and /usr/ports/Mk/ has:

---- begin snippet ----
.if ${OSVERSION} < 500016
PTHREAD_LIBS=       -pthread
PTHREAD_LIBS=       -lc_r
---- end snippet ----

And the source tarball still runs fine.

> I ran configure with exact the same args and environment, but it
> did not behave like the port does. But I think environment isn't really
> exact the same since there were some default portsettings which I
> missed.

This is my assumption too.

I placed:

        echo ${CONFIGURE_ENV}

In the port Makefile and ran make. This gave me:

CPPFLAGS=-I/usr/local/include -D_THREAD_SAFE LDFLAGS=-L/usr/local/lib -lc_r SHELL=/bin/sh CONFIG_SHELL=/bin/sh PORTOBJFORMAT=elf MAKE=gmake GTKDOC=false ESD_CONFIG=/usr/local/bin/esd-config

So I then went to my source tarball and ran:

    CPPFLAGS="-I/usr/local/include -D_THREAD_SAFE"  LDFLAGS="-L/usr/local/lib -lc_r" SHELL=/bin/sh CONFIG_SHELL=/bin/sh PORTOBJFORMAT=elf MAKE=gmake  GTKDOC="false"  ESD_CONFIG="/usr/local/bin/esd-config" ./configure

(Which, to the best of my knowledge is exactly what the port Makefile is

And the source tarball still compiled and ran fine. I even checked
the PATH env var, and it's identical to the path I'm using to build
my source tarball.

I'm stumped folks.

Jesse Guardiani, Systems Administrator
WingNET Internet Services,
P.O. Box 2605 // Cleveland, TN 37320-2605
423-559-LINK (v)  423-559-5145 (f)

More information about the freebsd-ports mailing list