mplayer port

Andy Harrison ah51 at
Thu Oct 23 09:05:48 PDT 2003


Anyone else have trouble with the gui?

It starts and plays fine for me, but when I try to click any options that bring
up a new window (prefs, skins, etc) I see the window flash onto the screen and
then vanish very quickly.  Play/Stop/etc buttons and volume control work fine.

Here is the startup sequence.

> gmplayer -skin CornerMP-aqua
MPlayer 0.92-2.95.4  (C) 2000-2003 MPlayer Team
CPU: Intel  (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /usr/local/share/mplayer/mplayer.conf: No such file or
Reading config file /home/aharrison/.mplayer/config
[cfg] read config file: /home/aharrison/.mplayer/gui.conf
Reading config file /home/aharrison/.mplayer/gui.conf
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/aharrison/.mplayer/codecs.conf: can't open
'/home/aharrison/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/share/mplayer/codecs.conf: 50 audio & 136 video codecs
Font /usr/local/share/mplayer/fonts/iso-8859-1/arial-18/font.desc loaded
successfully! (206 chars)
Using usleep() timing
Can't open input config file /home/aharrison/.mplayer/input.conf: No such file
or directory
Input config file /usr/local/share/mplayer/input.conf parsed: 52 binds
SKIN dir 1: '/home/aharrison/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
<snip - starts playing the url>

I have tried without any skins, I've tried monkeying with the fonts, I've tried
numerous ways, but can't get the gui to function properly.

Andy Harrison
Great Works Internet
System Operations
(full headers for details)

Version: PGP 6.5.8


More information about the freebsd-ports mailing list