FreeBSD Port: libglut-5.0.2

Eric Anholt anholt at
Mon Nov 10 12:34:54 PST 2003

On Mon, 2003-11-10 at 10:46, Simon Dassow wrote:
> Hi,
> is there something known to be broken?
> I recently wanted to make and got the following error:
> Warning: Object directory not changed from original
> /usr/ports/graphics/libglut/work/Mesa-5.0.2/src-glut
> cc -fpic -DPIC -O -pipe -march=k6 -I../include -I/usr/X11R6/include  -c
> glut_cindex.c -o glut_cindex.So
> /usr/libexec/elf/ld: cannot find -lGL
> *** Error code 1
> Stop in /usr/ports/graphics/libglut/work/Mesa-5.0.2/src-glut.
> I'm using the nvidia-driver, so i dont know if it matters, but i think
> it shouldn't.
> The way i fixed it, or better worked around it:
> # cd /usr/ports/graphics/libglut/work/Mesa-5.0.2/src-glut
> # make |grep cc| sed -e 's#\(-I/usr/X11R6/include\)#\1
> -L/usr/X11R6/lib#'
> # cc -fpic -DPIC -O -pipe -march=k6 -I../include -I/usr/X11R6/include
> -L/usr/X11R6/lib -c glut_cindex.c -o glut_cindex.So
> Then i got the next error... i've did it the same way like written above
> for... about 20 times.
> Seems now i have glut working.
> Is this related to the nvidia-driver?

Yes, it's apparently related to the nvidia driver.  I'm not sure why. 
I'll take a look at this RSN.

(I was really hoping I could avoid ever installing the nvidia driver. 

Eric Anholt                                eta at          anholt at

More information about the freebsd-ports mailing list