firebird and xemacs locking up/crashing "in pairs"???

Palle Girgensohn girgen at
Fri Nov 28 02:53:30 PST 2003

native. 0.6.x worked perfect, it happened when switching to gtk2.

An note: I use windowmanager, some here use enlightenment, noone use 
gnome/kde and we all use "focus follows mouse", no clicking to activate a 
window. I tried gnome to see if I could reproduce it there. Although I 
didn't cope with it for very long, the problem did not arise. Perhaps I 
didn't try long enough, or perhaps it is related to the focus setting. Ther 
reason I suspect it this:

When switching workspaces using keyboard shortcut, if the mouse pointer is 
placed so it is over two firebird windows, X cannot decide on which window 
to focus, and switches focus between the two windows as fast as it can, 
more than ten times / s, until I manually click a window title bar to force 
focus. I've never seen this happen ever before, but I've not used gtk2 much 
until now. See "image" for a clearer description :)  mouse pointer is the 

|                |
|             -- |-----------
|            |   |           |
|            | ^ |           |
|            | | |           |
|            |   |           |
|            |   |           |
|            |   |           |
-----------------            |
             |               |

Also, sometimes, focus works bad and I cannot write any text in the 
firebird window. refocusing by switching to another window and back usually 
resolves it, but this is a first sign that it will eventually lock up as 
described before.

I have seen this on different sites (at home and at the office), but I 
always use "focus follows mouse". I will try changing focus strategy in 
windowmanager and see if this helps.


--On fredag, november 28, 2003 11.24.59 +0100 Gary Jennejohn 
<garyj at> wrote:

> Palle Girgensohn writes:
>> Well, shutting off type-ahead-search (the single best feature of
>> firebird,=20 btw) does not really help. I cannot reproduce the core dump
>> as before, but=20 firebird and xemacs still lock up in pairs. Just had
>> this experience, and=20 firebird would work even though I killed all its
>> processes and restarted=20 the application! Firebird shoed up, but never
>> tried accessing any URLs.=20 Started mozilla instead, worked fine...
>> Then I realized that xemacs was=20 hung, killed it and bingo, firebird
>> works again. Is this also a known=20 problem?
> Are you using Linux-firebird or a natively compiled firebird? AFAIK
> I've never seen the problems you describe while using xemacs and the
> Linux-firebird together.
> ---
> Gary Jennejohn / garyj[at] gj[at] gj[at]

More information about the freebsd-ports mailing list