FreeBSD Port: libglut-5.0.2

Simon Dassow janus at
Mon Nov 10 10:46:32 PST 2003

is there something known to be broken?
I recently wanted to make and got the following error:

Warning: Object directory not changed from original
cc -fpic -DPIC -O -pipe -march=k6 -I../include -I/usr/X11R6/include  -c
glut_cindex.c -o glut_cindex.So
/usr/libexec/elf/ld: cannot find -lGL
*** Error code 1

Stop in /usr/ports/graphics/libglut/work/Mesa-5.0.2/src-glut.

I'm using the nvidia-driver, so i dont know if it matters, but i think
it shouldn't.
The way i fixed it, or better worked around it:

# cd /usr/ports/graphics/libglut/work/Mesa-5.0.2/src-glut
# make |grep cc| sed -e 's#\(-I/usr/X11R6/include\)#\1
# cc -fpic -DPIC -O -pipe -march=k6 -I../include -I/usr/X11R6/include
-L/usr/X11R6/lib -c glut_cindex.c -o glut_cindex.So

Then i got the next error... i've did it the same way like written above
for... about 20 times.

Seems now i have glut working.

Is this related to the nvidia-driver?


More information about the freebsd-ports mailing list