FreeBSD Port: vpopmail-5.3.27

Mark Skurzynski mark at
Thu Nov 6 08:59:20 PST 2003

Thanks Peter! I've touch'd the file and the new domain was added. Where
can I find the information that belongs inside the file? Google didn't
help out much (I was shocked).

In regards to the pop3 .. no, there's no errors anywhere. I've seen
the error myself while checking my email a few times today along with
a few customers reporting it. Checking the log files shows no failed
attempts from my IP address even though Outlook Express popped up a
box asking for my login/password again then when I hit ok it worked
normally the second time around.

I used to run the vpopmail-stable port but was forced to upgrade when
the qmailadmin port was upgraded. Pretty much since then I've been seeing
this issue at random.

One other thing when the server asks again for my login/pass I check
the processes and see a qmail-pop3d process running (not from my login)
under the vpopmail username. As soon as I kill that one I can connect fine
but not until then. Checking that process further yeilds its just other
people checking their mail. Perhaps 2+ people can't check their email at
exactly the same time? A configuration variable somewhere maybe?

I've re-installed qmail, vpopmail, qmailadmin, everything, along with
first upgrading to the latest 4.9-stable and the problem still exists.
I'm really stumped! Any idea?

  Mark Skurzynski  *  Lomag Internet Services, LLC
  mark at   *
  Edison, NJ USA   *  908-754-2296
----- Original Message ----- 
From: "Peter Pentchev" <roam at>
To: "Mark Skurzynski" <mark at>
Cc: <ports at>
Sent: Thursday, November 06, 2003 11:44 AM
Subject: Re: FreeBSD Port: vpopmail-5.3.27

On Thu, Nov 06, 2003 at 11:09:37AM -0500, Mark Skurzynski wrote:
> Hi Guys,
> It looks like something is wrong with the latest vpopmail-5.3.29 update.
> [11:05](root at web)[/usr/local/vpopmail/bin]# ./vadddomain 2037564
> Error: (vadduser) can't read domain limits
> [11:05](root at web)[/usr/local/vpopmail/bin]# ./vadddomain 2037564
> Error: Domain already exists
> [11:05](root at web)[/usr/local/vpopmail/bin]# ./vdeldomain
> Failed to delete dir_control for
> [11:05](root at web)[/usr/local/vpopmail/bin]# ./vdeldomain
> Error: Domain does not exist

Try creating an empty /usr/local/vpopmail/etc/vlimits.default file;
I seem to have missed the need for this file during the installation :(

> After the first vadddomain you can not login via qmailadmin. The vadd
> says the domain exists (still can't login). Trying to delete it produces
> the above dir_control error too. Any ideas? This all worked perfectly
> in 5.3.28.

The vlimits.default file's existence should fix that.

> I've also been noticing a strange issue with POP3 authentication. Upon
> first connecting to POP3 each morning the server would reject a users
> login/password but when re-entered exactly the same it works the second
> time. Occasionally also the system would just reject a a valid/login password
> but eventually accept it.

Are there any error messages in the mail log? (usually /var/log/maillog)


Peter Pentchev roam at    roam at    roam at
PGP key:
Key fingerprint FDBA FD79 C26F 3C51 C95E  DF9E ED18 B68D 1619 4553
This sentence is false.

More information about the freebsd-ports mailing list