ports/99629: "dri-devel" port still wont build even with latest update.

Vincent Howell darkvincentdude at yahoo.com
Fri Jun 30 02:50:56 UTC 2006

>Number:         99629
>Category:       ports
>Synopsis:       "dri-devel" port still wont build even with latest update.
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    freebsd-ports-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Jun 30 02:50:16 GMT 2006
>Originator:     Vincent Howell
>Release:        6.1-RELEASE
FreeBSD pentium.gateway.2wire.net 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Sun May  7 04:32:43 UTC 2006     root at opus.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386

The dri-devel port building process fails once again with a new error:

./../bin/mklib -o GLw -linker 'cc' \
        -major 1 -minor 0 -patch 0 \
         -install ../../lib \
        -L../../lib -L/usr/X11R6/lib -lGL -lXt -lXm -lX11 GLwDrawA.o
mklib: Making FreeBSD shared library:  libGLw.so.1
/usr/bin/ld: cannot find -lXm
mklib: Installing libGLw.so.1 libGLw.so in ../../lib 
mv: rename libGLw.so.1 to ../../lib/libGLw.so.1: No such file or directory
gmake[3]: *** [../../lib/libGLw.so] Error 1
gmake[3]: Leaving directory `/usr/ports/graphics/dri-devel/work/Mesa/src/glw'
gmake[2]: *** [subdirs] Error 1
gmake[2]: Leaving directory `/usr/ports/graphics/dri-devel/work/Mesa/src'
gmake[1]: *** [default] Error 1
gmake[1]: Leaving directory `/usr/ports/graphics/dri-devel/work/Mesa'
gmake: *** [freebsd-dri-x86] Error 2
*** Error code 2

Stop in /usr/ports/graphics/dri-devel.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall8430.0 make PORT_UPGRADE=yes
** Fix the problem and try again.
--->  Install tasks: 1
--->  Summary: 0 done, 0 ignored, 0 skipped and 1 failed
** Listing the failed packages (*:skipped / !:failed)
        ! graphics/dri-devel    (unknown build error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

Note: I tried installing libGL from ports but it requests a legacy Xorg port (X11R6.8.1) and would overwrite the installed Xorg 6.9. I did try to disable dependency checking but it still tried to download for some reason.

Perhaps fowarding an updated libGL to the ports tree can fix that?

Comment: It seems to me this port just doesnt want to behave and thats sad because I own a R300 series card (Radeon 9600 XT) and can benefit from the latest DRI snapshots (R300+ chipsets still arn't well supported yet). :-(

cd /usr/ports/graphics/dri-devel/ && make install

More information about the freebsd-ports-bugs mailing list