ports/98718: portversion misses some needed updates

Neil Darlow neil at darlow.co.uk
Thu Jun 8 22:00:52 UTC 2006


>Number:         98718
>Category:       ports
>Synopsis:       portversion misses some needed updates
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Jun 08 22:00:35 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Neil Darlow
>Release:        FreeBSD 4.11-RELEASE-p18 i386
>Organization:
>Environment:
System: FreeBSD router.darlow.co.uk 4.11-RELEASE-p18 FreeBSD 4.11-RELEASE-p18 #0: Thu Jun 1 18:47:03 BST 2006 neil at router.darlow.co.uk:/usr/obj/usr/src/sys/ROUTER i386
>Description:
portversion does not always agree with pkg_version on packages requiring
		an update. portupgrade -arR does update the packages indicated by pkg_version.
		I have observed this problem on FreeBSD-4.11 with ruby18-bdb1 and
		FreeBSD-6.1 with ruby18-bdb43.
>How-To-Repeat:
1) update ports with cd /usr/src && make update && portsdb -Fu
		2) compare output of pkg_version |grep '<' and portversion |grep '<' (the
		   portversion output may show fewer packages to update).
		3) upgrade ports with portupgrade -arR which updates all packages listed
		   by pkg_version |grep '<'
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list