[package - 121arm64-quarterly][devel/py-pyinstaller] Failed for py27-pyinstaller-3.5_1 in build

pkg-fallout at FreeBSD.org pkg-fallout at FreeBSD.org
Tue Dec 29 01:59:38 UTC 2020


You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     python at FreeBSD.org
Last committer: linimon at FreeBSD.org
Ident:          $FreeBSD: branches/2020Q4/devel/py-pyinstaller/Makefile 535707 2020-05-18 01:56:05Z linimon $
Log URL:        http://ampere1.nyi.freebsd.org/data/121arm64-quarterly/559529/logs/py27-pyinstaller-3.5_1.log
Build URL:      http://ampere1.nyi.freebsd.org/build.html?mastername=121arm64-quarterly&build=559529
Log:

=>> Building devel/py-pyinstaller
build started at Tue Dec 29 01:59:28 UTC 2020
port directory: /usr/ports/devel/py-pyinstaller
package name: py27-pyinstaller-3.5_1
building for: FreeBSD 121arm64-quarterly-job-09 12.1-RELEASE FreeBSD 12.1-RELEASE arm64
maintained by: python at FreeBSD.org
Makefile ident:      $FreeBSD: branches/2020Q4/devel/py-pyinstaller/Makefile 535707 2020-05-18 01:56:05Z linimon $
Poudriere version: 3.2.8-8-gaf08dbda
Host OSVERSION: 1300121
Jail OSVERSION: 1201000
Job Id: 09

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1201000
UNAME_v=FreeBSD 12.1-RELEASE
UNAME_r=12.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-8-gaf08dbda
MASTERMNT=/usr/local/poudriere/data/.m/121arm64-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/121arm64-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=121arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/121arm64-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=py27
DEPENDS_ARGS=
MAKE_ARGS= FLAVOR=py27
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for py27-pyinstaller-3.5_1:
     DOCS=on: Build and/or install documentation
     MANPAGES=on: Build and/or install manual pages
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
python at FreeBSD.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27  XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27  HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27  XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27  HOME=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27 TMPDIR="/tmp" PATH=/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LDSHARED="cc -shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" DOCS="" NO_DOCS="@comment " MANPAGES="" NO_MANPAGES="@comment " PYTHON_INCLUDEDIR=include/python2.7  PYTHON_LIBDIR=lib/python2.7  PYTHON_PLATFORM=freebsd12  PYTHON_SITELIBDIR=lib/python2.7/site-packages  PYTHON_SUFFIX=27  PYTHON_VER=2.7  PYTHON_VERSION=python2.7 PYTHON2="" PYTHON3="@comment " OSREL=12.1 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/py27-pyinstaller"  EXAMPLESDIR="share/examples/py27-pyinstaller"  DATADIR="share/py27-pyinstaller"  WWWDIR="www/py27-pyinstaller"  ETCDIR="etc/py27-pyinstaller"
--End PLIST_SUB--

--SUB_LIST--
DOCS="" NO_DOCS="@comment " MANPAGES="" NO_MANPAGES="@comment " PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/py27-pyinstaller DOCSDIR=/usr/local/share/doc/py27-pyinstaller EXAMPLESDIR=/usr/local/share/examples/py27-pyinstaller  WWWDIR=/usr/local/www/py27-pyinstaller ETCDIR=/usr/local/etc/py27-pyinstaller
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1) Target: aarch64-unknown-freebsd12.1 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1) Target: aarch64-unknown-freebsd12.1 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1) Target: aarch64-unknown-freebsd12.1 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=aarch64
OPSYS=FreeBSD
_OSRELEASE=12.1-RELEASE
OSREL=12.1
OSVERSION=1201000
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  1048576
stack size              (kbytes, -s)  1048576
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.

===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-pyinstaller-3.5_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.15.10.txz
[121arm64-quarterly-job-09] Installing pkg-1.15.10...
[121arm64-quarterly-job-09] Extracting pkg-1.15.10: .......... done
===>   py27-pyinstaller-3.5_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py27-pyinstaller-3.5_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.

===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by py27-pyinstaller-3.5_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.

===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by py27-pyinstaller-3.5_1 for building
=> SHA256 Checksum OK for PyInstaller-3.5.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.
<snip>
Since version 1.25 HTTPS connections are now verified by default which is done
via "cert_reqs = 'CERT_REQUIRED'".  While certificate verification can be
disabled via "cert_reqs = 'CERT_NONE'", it's highly recommended to leave it on.

Various consumers of net/py-urllib3 already have implemented routines that
either explicitly enable or disable HTTPS certificate verification (e.g. via
configuration settings, CLI arguments, etc.).

Yet it may happen that there are still some consumers which don't explicitly
enable/disable certificate verification for HTTPS connections which could then
lead to errors (as is often the case with self-signed certificates).

In case of an error one should try first to temporarily disable certificate
verification of the problematic urllib3 consumer to see if that approach will
remedy the issue.
--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-requests-2.22.0:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-pystemmer-2.0.0.1:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-snowballstemmer-1.2.1:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-sphinx_rtd_theme-0.4.3:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-sphinxcontrib-websupport11-1.1.2:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-typing-3.7.4.1:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
=====
Message from py27-sphinx18-1.8.5_2,1:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
===>   py27-pyinstaller-3.5_1 depends on package: py27-sphinx18>0 - found
===>   Returning to build of py27-pyinstaller-3.5_1
===>   py27-pyinstaller-3.5_1 depends on package: py27-sphinx18>0 - found
===>   py27-pyinstaller-3.5_1 depends on package: py27-setuptools>0 - found
===>   py27-pyinstaller-3.5_1 depends on file: /usr/local/bin/python2.7 - found
===>   py27-pyinstaller-3.5_1 depends on package: gmake>=4.3 - not found
===>   Installing existing package /packages/All/gmake-4.3_2.txz
[121arm64-quarterly-job-09] Installing gmake-4.3_2...
[121arm64-quarterly-job-09] Extracting gmake-4.3_2: .......... done
===>   py27-pyinstaller-3.5_1 depends on package: gmake>=4.3 - found
===>   Returning to build of py27-pyinstaller-3.5_1
===>   py27-pyinstaller-3.5_1 depends on package: py27-dis3>0 - not found
===>   Installing existing package /packages/All/py27-dis3-0.1.3.txz
[121arm64-quarterly-job-09] Installing py27-dis3-0.1.3...
[121arm64-quarterly-job-09] Extracting py27-dis3-0.1.3: .......... done
=====
Message from py27-dis3-0.1.3:

--
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.
===>   py27-pyinstaller-3.5_1 depends on package: py27-dis3>0 - found
===>   Returning to build of py27-pyinstaller-3.5_1
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-pyinstaller-3.5_1
running config
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-pyinstaller-3.5_1
cd /wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/PyInstaller-3.5/bootloader &&  /usr/local/bin/python2.7 waf all
'all' finished successfully (0.002s)
'distclean' finished successfully (0.000s)
Setting top to                           : /wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/PyInstaller-3.5/bootloader 
Setting out to                           : /wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/PyInstaller-3.5/bootloader/build 
Python Version                           : 2.7.18 (default, Dec 10 2020, 10:26:31) [GCC 4.2.1 Compatible FreeBSD Clang 8.0.1 (tags/RELEASE_801/final 366581)] 
Checking for 'clang' (C compiler)        : /usr/bin/clang 
Checking size of pointer                 : 8 
Platform                                 : FreeBSD-64bit detected based on compiler 
Checking for flags -m64                  : yes 
Checking for program '/usr/bin/strip'    : /usr/bin/strip 
Checking for program 'strip'             : /usr/bin/strip 
Checking for library thr                 : yes 
Checking for library m                   : yes 
Checking for library z                   : yes 
Checking for function unsetenv           : yes 
Checking for function mkdtemp            : yes 
'configure' finished successfully (0.826s)
'make_all' finished successfully (0.012s)
Waf: Entering directory `/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/PyInstaller-3.5/bootloader/build/debug'
[ 1/13] Compiling src/pyi_python.c
[ 2/13] Compiling src/pyi_global.c
[ 3/13] Compiling src/main.c
[ 4/13] Compiling src/pyi_archive.c
[ 5/13] Compiling src/pyi_utils.c
[ 6/13] Compiling src/pyi_launch.c
[ 7/13] Compiling src/pyi_path.c
[ 8/13] Compiling src/pyi_python27_compat.c
[ 9/13] Compiling src/pyi_main.c
[10/13] Compiling src/pyi_win32_utils.c
[11/13] Compiling src/pyi_pythonlib.c
In file included from ../../src/main.c:20:
In file included from /usr/include/floatingpoint.h:3:
/usr/include/machine/ieeefp.h:36:1: error: unknown type name '__BEGIN_DECLS'
__BEGIN_DECLS
^
/usr/include/machine/ieeefp.h:37:1: error: expected identifier or '('
extern fp_rnd_t    fpgetround(void);
^
/usr/include/machine/ieeefp.h:41:1: error: unknown type name '__END_DECLS'
__END_DECLS
^
In file included from ../../src/main.c:31:
In file included from /usr/include/stdlib.h:40:
In file included from /usr/include/sys/_types.h:35:
/usr/include/machine/_types.h:45:1: error: expected identifier or '('
typedef signed char             __int8_t;
^
/usr/include/machine/_types.h:70:9: error: unknown type name '__int8_t'; did you mean '__uint8_t'?
typedef __int8_t        __int_least8_t;
        ^
/usr/include/machine/_types.h:46:24: note: '__uint8_t' declared here
typedef unsigned char           __uint8_t;
                                ^
5 errors generated.

Waf: Leaving directory `/wrkdirs/usr/ports/devel/py-pyinstaller/work-py27/PyInstaller-3.5/bootloader/build/debug'
Build failed
 -> task in 'run_d' failed with exit status 1 (run with -v to display more information)
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-pyinstaller


More information about the freebsd-pkg-fallout mailing list