Poor Samba throughput on 6.0

Joao Barros joao.barros at gmail.com
Thu Nov 10 20:21:12 PST 2005

On 11/9/05, Jeremie Le Hen <jeremie at le-hen.org> wrote:
> Hi, Joao,
> > Last month I started a thread[1] on current@ about this, but I guess I
> > should have done it here, my apologies for that.
> >
> > After my initial post I did some more testing and I'm going to start
> > clean here with all my findings :)
> >
> > I started with Samba 3 installed on a PIII 733MHz with fxp (82559) and
> > a RAID5 consisting of 4 drives connected to an amr.
> > Performance reading or writing was poor, around 5.5MB/s measured on
> > two Windows clients and iostat never topped that by much.
> > cpu was mbufs were available and there were no IRQs shared.
> > To dismiss the amr out of the question I tried with a local IDE
> > attached yielding the same results.
> > I then tested the same on a machine I have at work, an HP Proliant
> > server, Pentium 4 3.06GHz, used SMP instead of GENERIC to use HTT.
> > I could get 8MB/s with 2 read or write simultaneous operations. With 1
> > operation I still can only get 6MB/s
> > This machine has 1GB ram and after copying a 700MB file to it it was
> > all cached.
> > A copy to dev/null took 1 second.
> > A copy via samba took the same time as if there was no cache for it.
> > iostat always showed 0.0 during the operation so that pretty much
> > takes disks, controllers, IO out of the picture.
> >
> > Both machines have cpu, IO and mbufs to spare and they still can't use
> > them. Why?
> I won't be able to help you much, but as almost nobody answered you,
> I take it for the moment in order to ask you some more informations.
> Which scheduler are you using, 4BSD or ULE ?  It might be worth testing
> the other one and sending us the new benchmark results.

The testings were all with either GENERIC or SMP thus using 4BSD, I
can try ULE and see if I get any different results.

> Also, if you are able to remove a drive from your RAID5, you can try
> R/W performances from/to it, without using amr(4), both with 4BSD and
> ULE.

I tried using a single drive, an IDE and a SCSI-2 and on 2 machines at
work both with a RAID1.
Even better, there is a part in my initial email where I mention that
having a 700MB file cached (iostat reported no reads) the results were
the same. With this in mind I don't think the problem is at the
storage level.

Joao Barros

More information about the freebsd-performance mailing list