ethernet rate limiting??

fabulous fabulous at
Tue Jul 13 12:35:10 PDT 2004

I would play with these values:
net.inet.tcp.sendspace: 65536
net.inet.tcp.recvspace: 65536

try increasing sendspace to 524288 or more :P (this can eat lots of 
mbufs btw, but you have lots free)


Dmitry Alyabyev wrote:
> On Tuesday 13 July 2004 06:07, Joe wrote:
>> Here goes for a first post.
>>I run an mldonkey server under 4.10-STABLE (though I noticed the same
>>behaviour under 4.8 and 4.9). It also runs samba and ssh2 all on a
>>Generally what happens is I download files to this fbsd server and
>>share them to my other pc via samba. When first rebooted this
>>works fine with full ethernet copy speeds.
>>After a while copying files from the fbsd box to the pc rate limits
>>to 40k (via smb/ftp/ssh2 whichever) over the ethernet lan. This is on
>>100mbit cards I've tried different cables/cards/switches etc with no luck.
>>I'm guessing there is some memory/network/file descriptor limit I'm
>>hitting and I've no idea how to extend it or clear it.
> i think the problem is wrong duplex negotiation
> try to set it manually on switch port and ethernet card

More information about the freebsd-performance mailing list