ethernet rate limiting??

Joe ce018 at
Mon Jul 12 20:10:14 PDT 2004

 Here goes for a first post.
I run an mldonkey server under 4.10-STABLE (though I noticed the same
behaviour under 4.8 and 4.9). It also runs samba and ssh2 all on a
Generally what happens is I download files to this fbsd server and
share them to my other pc via samba. When first rebooted this
works fine with full ethernet copy speeds.
After a while copying files from the fbsd box to the pc rate limits
to 40k (via smb/ftp/ssh2 whichever) over the ethernet lan. This is on
100mbit cards I've tried different cables/cards/switches etc with no luck.
I'm guessing there is some memory/network/file descriptor limit I'm
hitting and I've no idea how to extend it or clear it.
I've made the following mods in sysctl.conf
and in kernconf
machine         i386
cpu             I686_CPU
maxusers        512
options         NMBCLUSTERS=16384
options         NMBUFS=32768
sample output from netstat -m
149/944/32768 mbufs in use (current/peak/max):
        101 mbufs allocated to data
        48 mbufs allocated to packet headers
73/348/16384 mbuf clusters in use (current/peak/max)
932 Kbytes allocated to network (2% of mb_map in use)
0 requests for memory denied
0 requests for memory delayed
0 calls to protocol drain routines
# netstat -an | grep tcp4 | wc -l
Does anybody have any suggestions or ideas as to optimize this or
have I hit some limit that can't be exceeded?
thanks again,

More information about the freebsd-performance mailing list