CUPS Printing setup problems.

HarryH forHarryH at
Thu Aug 12 23:14:29 PDT 2004

I have FreeBSD 4.10 installed and decided make it a print server using CUPS instead of LPD.  I followed all instructions and have CUPS up and running.  When I print a test page, CUPS acts as though all is fine and declares the job "completed" yet there is not output to the printer and nothing in the print queue.  A problem (see below) appears to be where Perl cannot find the Locale.  I set LANG, LC_ALL and LC_CTYPE all equal to en_US.ISO.8859-1 in the .cshrc script for startup but it does not work.  I added DefaultLanguage=en_US.ISO.8859-1 in the cupsd.conf file - still no change.  When I do a "env" to check the variables, all of them look good and set correctly.  
I have spent days all over the Web but have yet to find any answers that work.  It appears to me that Perl is trying to get the LANG and other variables from some other place but where?  I checked the locale directories in /usr/share/locale and all seems to be there.

One site Linux suggested that they fixed it by adding $ENV {'LC_ALL'} = 'en_US'; to some Perl startup script, but I do not know Perl and where its parts are.   Any ideas as to what I need to do to fix this?  

Any suggestions GREATLY appreciated!

Harry Heim   
couldn't set locale correctly
D [11/Mar/2004:02:38:33 +0500] [Job 55] perl: warning: Setting locale failed.
D [11/Mar/2004:02:38:33 +0500] [Job 55] perl: warning: Please check that your
locale settings:
D [11/Mar/2004:02:38:33 +0500] [Job 55] LC_ALL = (unset),
D [11/Mar/2004:02:38:33 +0500] [Job 55] LANG = "en"
D [11/Mar/2004:02:38:33 +0500] [Job 55] are supported and installed on your
D [11/Mar/2004:02:38:33 +0500] [Job 55] perl: warning: Falling back to the
standard locale ("C").

More information about the freebsd-performance mailing list