bce(4) sees all incoming frames as 2026 bytes in length

pluknet pluknet at gmail.com
Wed Apr 29 14:00:00 UTC 2009

2009/4/29 Nikolay Denev <ndenev at gmail.com>:
> Hash: SHA1
> Hello,
> I have the following problem with the new bce(4) driver on a 7.2-PRERELEASE
> from a few days ago.
> When I run tcpdump on the bce interface on the machine, all incoming frames
> are shown as 2026 in size,
> but on the sending machine tcpdump reports that it's sending frames of the
> correct size.
> This looks very strange because I don't have enabled Jumbo Frames on this
> bce interface , and it is still with it's default MTU of 1500 bytes.
> When I tried to capture the packets, they are zero padded to the 2026 frame
> size. The checksums are correct, so I suspect a driver bug?
> P.S.: I experience this problem on several machines with bce interfaces, and
> on all of them tcpdump sees all incoming frames with length of 2026 bytes.


Please, give us more details. What is your network card model ?
Share ifconfig, dmesg...
I have a similar setup, except the frame size - mine are with expected values.


More information about the freebsd-net mailing list