bikeshed for all!

Julian Elischer julian at
Wed Dec 12 15:16:35 PST 2007

Max Laier wrote:
> On Wednesday 12 December 2007, Julian Elischer wrote:
>> So, I'm playing with some multiple routing table support..
>> the first version is a minimal impact version with very limited
>> functionality. It's done that way so I can put it in RELENG_6/7 without
>> breaking ABIs (I hope). Later there will be a more flexible version
>> for-current.
>> Here's the question..
>> I need a word to use to describe the network view one is currently on..
>> e.g. if you are usinghe second routing table, you could say I've set
>> xxx to 1 (0 based)..
>> current;y in my code I'm using 'universe' but I don't like that..
>> one could think of it as a routing plane..
>> each routing plane has he same interfaces on it but they are logically
>> treated differently becasue each plane has a different routing table.
>> so here's an axample of  it in use now...
>> the names should change...
>> setuniverse 1 netstat -rn
>> [shows table 1]
>> setuniverse 2 route add
>> setuinverse 1 route add
>> setuniverse 2 route -n get
>> [shows]
>> setuniverse 1 route -n get
>> [shows]
>> setuniverse 2 start_apache
>> [appache starts, always using to reach the 10.0.0 net.
>> also the syscall is setuniverse()
>> so, you see I really need a better name....
>> setrtab?
>> rtab? rtbl?
>> and the command should be called "????"
> FWIW, OpenBSD just added a "-T num" switch to concerned programs like 
> route and netstat.  As far as I can tell they rely entirely on pf to 
> select a table - so there is no way to start a program "inside" a certain 
> network view.  OTOH, how - in your system - would you decide which table 
> to use for forwarded packets?

ipfw/pf/ipf rule (not yet added) :-)

> More to the bikeshed pov, "universe" seems rather broad.  "netview" comes 
> to mind.  "rtabselect", though that has a lot of characters, but then 
> again "setuniverse" is even one char longer ;)

More information about the freebsd-net mailing list