VAAPI not working with latest updates

Kevin Oberman rkoberman at
Fri Oct 5 20:19:28 UTC 2018

I'll start by admitting that I am not sure where to look about this, bu
after the last week's massive updates, all of my video players are failing.
I have tried mplayer, totem, mpv, xine and vlc. None work.

vlc give the most detailed error message (more than one line):
libva info: VA-API version 1.2.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/local/lib/dri/
libva info: Found init function __vaDriverInit_1_2
libva info: va_openDriver() returns 0
i965: Failed to submit batchbuffer: Input/output error
QObject::~QObject: Timers cannot be stopped from another thread

All others just show the i965 line.

I am assuming that VAAPI is the problem as I can use avidemux3_qt4 without
any problem and, as far as I can tell, it does not use VAAPI.

Running 11.2-stable r338990 and drm-stable-kmod. All ports are current as
of last night. GPU is Sandy Bridge.

I have not tried to play a video since 28-Sept. and a LOT of ports have
been touched since then, so VAPI may not be at issue, it just looks very
suspicious. I have tried rolling back libva and libva-intel-driver, to
2.2.0 but that did not help.

Any suggestions on what I might look at? I'm not happy about opening a PR
with so little to go by.
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: rkoberman at
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683

More information about the freebsd-multimedia mailing list