avidemux in ports

Kevin Oberman rkoberman at gmail.com
Wed Nov 1 00:46:57 UTC 2017

On Tue, Oct 31, 2017 at 11:07 AM, PÁSZTOR György <
pasztor at linux.gyakg.u-szeged.hu> wrote:

> Hi,
> Since I updated my ports (and unfortunately removed every previous working
> version) avidemux doesn't work. It seems no decoder and encoder plugins are
> available. Nor any container formats are recognised.
> I tried to install avidemux-plugins, but pkg says this:
> pkg: No packages available to install matching 'avidemux-plugins' have
> been found in the repositories
> However, it seems is somewhere there:
> https://svnweb.freebsd.org/ports/head/multimedia/avidemux-plugins/
> I assume, the plugins become broken at a certain point. Just this way,
> other avidemux packages are just useless.
> Isn't that an option / workaround, if someone put the last known working
> version of avidemux-plugins to that ports package and let the system use
> that?
> Cheers,
> Gyu

Odd. I have not seen this with the port. It works for for me except when it
crashes when resuming play after a pause (including dragging the cursor).

There is a problem on 11.1 or later caused by better memory checks and a
bug in qt4. The problem was introduced by 320666 of stable. It also impacts
current of recent times. I've tried to get a recent version to build, but
have gotten stuck with building the internal version of ffmpeg which does
not like the nasm in ports. (Errs out when testing for what version of nasm
is available.) Search  Bugzilla for multimedia/avidemux2 for my report for
more details.

In any case, I have not seen your issue. Have you tried adjusting config
options? Or are you installing the packages. more details might (or might
not) help.
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: rkoberman at gmail.com
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683

More information about the freebsd-multimedia mailing list