Problems with webcamd and RTL2832U

Greg 'groggy' Lehey grog at
Wed Apr 27 08:01:46 UTC 2016

I'm trying to set up MythTV on a 10.2-STABLE system using an RTL2832U
class tuner and webcamd webcamd-  The tuner probes as:

  Apr 27 12:36:40 tiwi devd: Executing 'logger Unknown USB device: vendor 0x0bda product 0x2838 bus uhub0'
  Apr 27 12:36:40 tiwi root: Unknown USB device: vendor 0x0bda product 0x2838 bus uhub0

These IDs are mentioned in,
along with the comment:

   Needs webcamd >=; seems to be only a bit less sensitive
   than my dib0700 tuners (worse reception in low-signal areas);
   remotes not supported yet by the Linux rtl28xxu driver and thus by
   webcamd; also supported by the comms/dabstick-radio and
   comms/rtl-sdr ports

I run webcamd with the invocation:

  webcamd -N RTL2838UHIDIR-Realtek -S 00000001 -M 0 -v 0 -B

This creates the devices:

  # ls -lR /dev/dvb/
  total 1
  dr-xr-xr-x  2 root  wheel  512 27 Apr 17:54 adapter0

  total 0
  crw-rw----  1 webcamd  webcamd  0x95 27 Apr 17:54 demux0
  crw-rw----  1 webcamd  webcamd  0x96 27 Apr 17:54 dvr0
  crw-rw----  1 webcamd  webcamd  0x97 27 Apr 17:54 frontend0

When I run mythtv-setup and try to access the tuner, I get the

  2016-04-27 17:27:43.168109 W  DiSEqCDevTree: No device tree for cardid 1
  2016-04-27 17:27:57.021513 W  DiSEqCDevTree: No device tree for cardid 1

ktrace tells me:

  3391 mythtv-setup CALL  openat(AT_FDCWD,0x8608eb598,0x2<O_RDWR>,<unused>0)
  3391 mythtv-setup NAMI  "/dev/dvb/adapter0/frontend0"
  3391 mythtv-setup RET   _umtx_op -1 errno 60 Operation timed out
  3391 mythtv-setup CALL  write(0x1,0x7fffdfbfb640,0x49)
  3391 mythtv-setup GIO   fd 1 wrote 73 bytes
       "2016-04-27 17:04:39.188786 W  DiSEqCDevTree: No device tree for cardid 1
  3391 mythtv-setup RET   write 73/0x49

There's nothing of importance between the attempt to open
/dev/dvb/adapter0/frontend0 and the error message, so clearly that's
the reason for the message, even if it's not quite appropriate.

I don't see any mention of rtl28xxu in current documentation, and no
way to specify a driver in the man page.  Can I assume that this is an
undocumented change?  Any ideas how to corner the problem?

Sent from my desktop computer.
Finger grog at for PGP public key.
See complete headers for address and phone numbers.
This message is digitally signed.  If your Microsoft mail program
reports problems, please read
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <>

More information about the freebsd-multimedia mailing list