xbmc-pvr-addons: on the way to xbmc pvr

Bernhard Fröhlich decke at bluelife.at
Sun Aug 18 14:12:41 UTC 2013


On Sun, Aug 18, 2013 at 3:13 PM, Juergen Lock <nox at jelal.kn-bremen.de> wrote:
> On Sat, Aug 17, 2013 at 11:23:50AM +0200, Bernhard Fröhlich wrote:
>> Hi guys,
> Hi!
>>
>> now that we have xbmc 12.2 and tvheadend in the portstree the next
>> step to a proper PVR solution running on FreeBSD is to add the xbmc
>> pvr addons that allow to use various backends like tvheadend.
>>
>> I have already created a port for the pvr addons that builds and
>> installs just fine but for some reason xbmc doesn't like them and
>> doesn't even display them in the GUI or any errors in the logfile.
>>
>> To try out the xbmc-pvr-addons port:
>> svn co https://svn.redports.org/decke/multimedia/xbmc-addon-pvr
>>
>> It should build and install fine but it doesn't seem to have any
>> effect on xbmc. You can also build ZIP packages for the addons that
>> you can try to install via the Addon manager.
>>
>> Build zip addons:
>> cd xbmc-addon-pvr && make && cd work/xbmc-pvr-addons-12.0-Frodo && make zip
>>
>> Install ZIP addons:
>> http://wiki.xbmc.org/index.php?title=Add-on_manager#How_to_install_from_a_ZIP_file
>>
>> With the ZIP files I always get "Add-on does not have the correct
>> structure" immediately. No log message that tells why it's
>> complaining.
>>
>>
>> There was one error in the logfile with stock multimedia/xbmc 12.2
>> that I fixed on the way:
>> ERROR: PVR - CreateTables - failed to get add-ons from the add-on manager
>>
>> I fixed it with the following patch that I also needed for xbmc-pvr-addons.
>> http://people.freebsd.org/~decke/patches/xbmc-12.2_1-addon-fix.diff
>>
>>
>> So we are pretty close to a working xbmc pvr because the requires
>> parts are all there already. We have an up-to-date xbmc 12.2 in the
>> tree. tvheadend with FreeBSD support from latest git is also available
>> in multimedia/tvheadend and works fine with webcamd devices. The
>> xbmc-pvr-addons port is also there already. All that is left is
>> getting that parts working in combination.
>>
>> I hope someone has an idea what is going on there or how to fix that. :o)
>>
>  I finally got around looking at this and turns out the fix is really
> simple if you know it:  xbmc seems to look for <platform>linux</platform>
> in the addon.xml files not freebsd.  I added back freebsd too in
> case this gets fixed later tho.  (first post-patch REINPLACE_CMD.)
>
> Index: Makefile
> ===================================================================
> --- Makefile    (revision 15743)
> +++ Makefile    (working copy)
> @@ -17,7 +17,6 @@
>  BUILD_DEPENDS+=        xbmc:${PORTSDIR}/multimedia/xbmc
>  RUN_DEPENDS+=  xbmc:${PORTSDIR}/multimedia/xbmc
>
> -PATCH_ARGS=    --suffix ""
>  USE_GL=                gl
>  USE_AUTOTOOLS= libtoolize aclocal libtool automake autoconf
>  MAKE_JOBS_SAFE=        yes
> @@ -29,8 +28,10 @@
>  .include <bsd.port.pre.mk>
>
>  post-patch:
> +       @${REINPLACE_CMD} 's|@OS@|freebsd linux|' \
> +               ${WRKSRC}/addons/*/addon/addon.xml.in
>         @${REINPLACE_CMD} 's|-ldl||' \
>                 ${WRKSRC}/addons/pvr.hts/Makefile.am
> -       @${RM} ${WRKSRC}/addons/*/*.orig
> +       @${RM} ${WRKSRC}/addons/*/*/*.orig
>
>  .include <bsd.port.post.mk>
>
>  HTH, :)
>         Juergen

Yay! It works fine now and the plugin is initialized and working now!
Thanks a lot for that hint but I am a bit curious why FreeBSD still
uses "linux" as platform. I think we should look into that and fix it
properly - but not today.

Now stay tuned for some XBMC Live-TV screenshots! :o)

-- 
Bernhard Fröhlich
http://www.bluelife.at/


More information about the freebsd-multimedia mailing list