Dragonfly USB DAC under 9.1-RELEASE

Hans Petter Selasky hps at bitfrost.no
Sun Apr 21 15:55:51 UTC 2013

On 04/21/13 01:53, Craig Leres wrote:
> Has anybody tried a Dragonfly USB DAC with FreeBSD 9.1-RELEASE? I picked
> up one last week can't quite get it to work
> My streamer is a Barix instreamer. I normally feed it with 48 KHz PCM
> from a Sirius Satellite radio receiver via toslink. I can also feed it
> directly with 44.1 KHz from VBR MP3s downloaded from amazon.com or 48
> KHz RIFF/WAVE files.
> I'm using the multimedia/xmms port with the OSS plugin. I use mpg123 to
> play MP3s. I think it uses OSS too. And obviously ossplay uses OSS.
> The DACs I have previously used are Realtek ALC883 and ALC888's on the
> motherboard of my desktop machines. With the Dragonfly plugged in,
> /dev/sndstat says:
>      ice 327 % cat /dev/sndstat
>      FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
>      Installed devices:
>      pcm0: <ATI R6xx (HDMI)> on hdaa0  (1p:1v/0r:0v)
>      pcm1: <Realtek ALC883 (Analog 7.1+HP/2.0)> on hdaa1  (1p:2v/2r:1v)
> default
>      pcm2: <USB audio> at ?  (1p:1v/0r:0v)
> (The Dragonfly is pcm2.)
> The first issue was a pop every 5 seconds. I noticed the LED was magenta
> which indicated the DAC was running at 96K so I looked at
> /sys/dev/sound/usb/uaudio.c and found that thd driver was defaulting to
> the highest sample rate the DAC reports. This meant my 48K input source
> was being upsampled.
> Looking at the driver a bit more I changed:
>      sysctl hw.usb.uaudio.default_rate=48000
> and removed/inserted the DAC and that fixes it at 48K (confirmed by a
> blue LED) and the 5 second pops are gone.
> Now I have noticeable audio glitches about ever minute or so. I don't
> think it's source material related. For example, if I play the same
> sound file over and over and note the number of seconds into the song
> when a glitch happens, it rarely happens at the same time.
> I tried to attach a short wav file of an example glitch but got a funny
> bounce ("550 5.7.1 Size too green"?) so I put a copy here:
>      http://xse.com/leres/scratch/glitch.wav
> Thinking it might be a ground loop problem, I got an Olimex USB-ISO USB
> isolator. It works ok but the glitches are still present.
> The Dragonfly sounds very nice so I hate to send it back; does anyone
> have suggestions for me? I called Audio Quest but the tech I talked to
> admitted he had only been trained for Windows and OSX.
> 		Craig


There are multiple options for debugging this issue.

1) Look at the usbdump utility for dumping the data communication for 
your device:

usbdump -i usbusX -f Y -s 65536

I suspect your device uses rate adaption, and that it does not work 

What does:

usbconfig -d X.Y dump_curr_config_desc


I use a Fasttracker over USB having eight 24-bit tracks at 96KHz, and 
that works just fine. Also all the additional mixer functionality is 
supported through extended pcm mixer sysctls.

See also:

sysctl hw.usb.uaudio.debug=15


More information about the freebsd-multimedia mailing list