Testing snd_hdspe - Was: [solved] snd_hdspe: No such file or directory

Ralf Mardorf ralf.mardorf at rocketmail.com
Fri Dec 28 08:48:36 UTC 2012

On Fri, 2012-12-28 at 12:27 +0400, Ruslan Bukin wrote:
> seems that your output is truncated.
> driver was detected RME AIO. But your card is RayDAT, right?

No, it's a RME HDSPe AIO. I'll reboot ASAP and try to get a complete
output, but this might take an hour or so, since I have to do office
work at the moment.

Perhaps there are different revisions of the HDSPe AIO available.
TotalMix for Linux detects the card as HDSPe AIO, but hardware info says
MADI. Here's some output I get for Linux:

spinymouse at q:~$ hdspmixer

HDSPMixer 1.11 - Copyright (C) 2003 Thomas Charbonnel <thomas at undata.org>
This program comes with ABSOLUTELY NO WARRANTY
HDSPMixer is free software, see the file COPYING for details

Looking for RME cards:
Card 0: RME AIO S/N 0x579bcc at 0xfdff0000, irq 18
RME AIO found!
Card 1: TerraTec EWX24/96 at 0xbf00, irq 20
Card 2: TerraTec EWX24/96 at 0xbb00, irq 21
Card 3: KORG INC. nanoKONTROL at usb-0000:00:13.0-2, full speed
Card 4: USB Device 0x170b:0x11 at usb-0000:00:13.1-1, full speed
1 RME cards card found.
Restoring last presets used
spinymouse at q:~$ hwinfo --sound
28: PCI 200.0: 0401 Multimedia audio controller                 
  [Created at pci.318]
  Unique ID: B35A.MZ+CP9Apr_E
  Parent ID: H0_h.9zE8Er2g1ED
  SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: sound
  Model: "Xilinx RME Hammerfall DSP MADI"
  Vendor: pci 0x10ee "Xilinx Corporation"
  Device: pci 0x3fc6 "RME Hammerfall DSP MADI"
  Revision: 0xd4
  Driver: "snd_hdspm"
  Driver Modules: "snd_hdspm"
  Memory Range: 0xfdff0000-0xfdffffff (rw,non-prefetchable)
  IRQ: 18 (134 events)
  Module Alias: "pci:v000010EEd00003FC6sv00000000sd00000000bc04sc01i00"
  Driver Info #0:
    Driver Status: snd_hdspm is active
    Driver Activation Cmd: "modprobe snd_hdspm"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

Alsamixer claims that the card is a "RME AIO_579bcc", hdspconf output is
"No Hammerfall DSP card found".

However, on Linux analog IOs are ok and ADAT IOs 1 and 2 are ok too, I
can't store alsamixer settings, but hdspmixer settings. I never tested
S/PDIF and AES. ADAT IOs 3 to 8 aren't available by jackd ports.

FWIW when I run FreeBSD I didn't load the Envy24 drivers and the USB
devices were not connected. The on-board audio devices are disabled by
the BIOS.


More information about the freebsd-multimedia mailing list