Can't play an audio CD

Michael D. Norwick mnorwick at
Sat Oct 22 03:10:29 UTC 2011

On 10/21/11 08:15, Stuart Barkley wrote:
> [Much of the original message trimmed.  See thoughts below.]
> On Thu, 20 Oct 2011 at 21:09 -0000, Michael D. Norwick wrote:
>> I am trying to get a Dell Latitude D630 laptop to play audio CD's
>> without success.
>> $uname -a
>> FreeBSD ****.****.net 9.0-RC1 FreeBSD 9.0-RC1 #1: Wed Oct 19 05:37:43 CDT 2011
>> michael@****.****.net:/usr/obj/usr/src/sys/KERNEL_101811  amd64
> I'm still using FreeBSD 8 on my main server.
>> I have rebooted several times and tried the old original freebsd 9
>> kernel (%boot kernel.orig) from the initial install with the same
>> result - can't play an audio CD.  I can now - mount_cd9660 - a data
>> CD with my custom kernel booted.  I know sound works because gnome
>> audio themes work.
> This is all good.
>> As was suggested, I have run the command line tools and have gotten
>> mixed results, such as;
>> $ camcontrol devlist
>> <TSSTcorp DVD+-RW TS-L632H D300>    at scbus1 target 0 lun 0 (pass0,cd0)
>> <ST980813ASG 3.ADD>                 at scbus2 target 0 lun 0 (ada0,pass1)
>> and;
>> $cdcontrol play 1
>> results in drive activity but again, no audio.
> The most likely case is that your system does not support direct audio
> from the CD drive and that you need to play your CDs with a different
> application (instead of just a hardware command).
> It used to be common for an audio signal cable to be connected
> directly from the CD drive to a specific CD input on the audio mixer.
> The 'cdcontrol play' command directs the CD drive to start playing
> audio.  After that everything was done in hardware/firmware with no
> further OS or application interaction needed.
> Many current system don't provide this direct audio connection
> anymore.  The audio mixers don't all have input connectors and I don't
> know if the audio output is even on current DVD drives.  I haven't
> paid attention on recent system hardware assemblies since I don't
> worry about this anymore.
> Things to try:
> We need to see the output of the 'mixer' command.  It is possible that
> the volume control for the CD input is set to 0.  My guess is that you
> don't even have a CD volume control.
> Look at the output from 'cdcontrol volume'.  My system shows 255 for
> the left and right channels.  It is possible that these are 0 on your
> system thus muting output.
> Try other audio player applications.  Some of them should support
> playing CDs directly.  These application will read the data from the
> drive and then send it to the system audio.  I don't use any of these
> anymore, I rip everything to mp3 files.
> Stuart
$ mixer
Mixer vol      is currently set to 100:100
Mixer pcm      is currently set to  75:75
Mixer speaker  is currently set to  75:75
Mixer rec      is currently set to  75:75
Recording source: monitor


$ cdcontrol volume
Left volume = 216, right volume = 216

with an audio CD in the drive after executing $cdcontrol play.  Still no 
sound from the thing and though I have external speakers plugged into 
the headphone out jack,  it doesn't matter if I unplug them.  I have 
tried gnome sound juicer and abraca without success.  I am using;

$pkg_info -a


In the Gnome multimedia selector tool, OSS is selected for default input 
and output.  The tests on that page produce sound when the test buttons 
are clicked.  Although I don't know why pulseaudio would not be a 
selection.  It is not.

Thank You,

More information about the freebsd-multimedia mailing list